Consistently weird results

Hi Everyone. Thanks for your help. After much tweaking and re-tweaking I’ve finally landed on a very fast setup for my wordpress site. I’ve got W3TC installed using Amazon for my CDN and on top of that, I’m using cloudflare.

Here’s my issue - my first time load is always about 1.5-1.7 seconds. Great. But my subsequent loads keep getting stuck on one file or another for 3 seconds. So my 2nd load is almost always significantly longer than my initial load.

See here for example:

Is it possible it’s the combination of Cloudflare + Amazon? I haven’t yet experimented with only using CF without the Amazon CDN.

I’d love to hear any suggestions!

The 3 second time is \the default time for retransmits on windows for socket connections when a packet is dropped. Is on Amazon or cloudflare? The packet loss could be a network problem or it could be intentional rate limiting.

In case you weren’t already aware, cloudflare is also a CDN so using cloud front (Amazon’s CDN) on top of it is possibly redundant.

Thanks for responding. is cloudfront.

I was thinking that it was possibly redundant. I’ll test it without using CF and see what happens. Thanks!

Well, I tried turning off the CF CDN and that’s definitely not the issue. Got the same results:

So it must be Cloudflare. Anyway to remedy this?

You can check the security settings in your control panel and see if ratcheting them down eliminates the problem for the test. If they were rate-limiting WPT I’d expect to see more consistent problems.

Might also ping their support team to see if there are any known network issues or attacks in the DC area. Do you see the same behavior from different test locations? It does seem really strange that it is consistently showing up only in repeat view tests and that it showed up both on Cloudflare and cloudfront. Normally I’d think it was a problem at the test location but I haven’t seen any other issues like that from Dulles.

Actually, I had forgotten that I had hard-coded a few links to theme images. Once I changed those back to the www url instead of the css url, things seemed to have cleared up.