Facing issues setting up WPT Private Instance on AWS

I am facing issues setting up WPT private Instance on AWS.

I am using this link as the guide

I have gone mostly with the default settings as detailed in the article. The server is setup in Oregon using ami-d7bde6e7 and I went with the default t2.micro for it. Only the basic settings listed in the article were setup.


Once the server was up and running, I am able to access the User interface and tried running a test in EU(London). The first test runs fine, but if I try doing a test again, it gets struck at the “Waiting at front of queue” screen and the result never comes.

Terminating the wpt agent instance helps sometimes as server launches a fresh instance to run the test.

Also one more thing that I noticed is that its sometimes launching the Linux ami in the same region along with windows even though I have only scheduled the test for the EU (London) which is windows.

I need a reliable setup as I want to integrate it with sitespeed for setting up a dashboard for continuous monitoring. Can someone help with the right AMIs, settings that I should be using for a reliable setup.

Does it help if I configure it to have one agent instance running all the time? But I need this only for London at the moment. Other regions are not relevant for me.

Just to give an update, I tried keeping the test agent alive by setting below and I had no problems with the tests. So for some reason, the test agent is not picking up the jobs with the default values.


Have you faced any issues where the tests do not complete ? I have been facing the same problem and checking the nginx logs shows me that the agents are polling the master for work but it doesn’t seem to return with the work.

Yes, for me too tests were getting struck with the default config. I could see from server logs that agent is polling for work, but tests don’t run. Some times the tests get struck in the middle of the run too. For example, if set 5 iterations for the test, it could get struck after 2 or 3.

After I change the config to keep the agent alive. I had no problems.