Getting error "net::ERR_INSUFFICIENT_RESOURCES" for Chrome only on private instances


I have created private WPT server and nodes using docker to run tests but getting a error “net::ERR_INSUFFICIENT_RESOURCES” for chrome only, it’s working fine for Firefox.

1 Use below command for server ::

sudo docker run -d -p 4000:80 -v path of file/locations.ini:/var/www/html/settings/locations.ini --restart=always webpagetest/server

2 Use below command for Node ::

sudo docker run -d -p 4001:80 --name wptagent -e “SERVER_URL=http://wpiserverIP:4000/work/” -e “LOCATION=which we mentioned in location.ini file” --cap-add=NET_ADMIN --restart=always webpagetest/agent

I have attached screenshots for the error.
Could anyone help me resolve this issue.

Ankit Jain

1 Like

I have got the solution, it’s required increase a memory.
Use “–shm-size=1gb” in docker command of Agent.

1 Like