Has Firefox abandoned HTTP/2 Server Push?

When I test the same page on Chrome and an Firefox 56, the latter does not seem to accept HTTP/2 server push anymore. I tried several instances, always with the same result: With Chrome, the pushed assets come in even before the html page does. With Firefox it looks like a classic HTTP 1 waterfall instead.

Here is one example from the same public instance:
Chrome: http://www.webpagetest.org/result/171108_S2_eaf05b5a8438bd303b3496ef4a47975c/
Firefox: http://www.webpagetest.org/result/171108_RY_ce0a9a3a6bfa6aa9f6d579d376fa22e4/

This was clearly different in earlier Firefox versions, e.g. here in Firefox 55: http://www.webpagetest.org/result/170824_KG_EXY/

Have others experienced this too? Any trick to make Firefox accept push again?

I believe they have it disabled temporarily while they fix some issues (though I can’t find the announcement right now and I may be remembering wrong).

I was just made aware of this bug report, which indicates that the problem in FF is solved in forthcoming version 59: https://bugzilla.mozilla.org/show_bug.cgi?id=1409570