Invalid JSON When Callback Specified


In October I wrote a script to retrieve results from runtest.php. I specified the format JSON and told it to use a callback URL, and it worked fine. I just tried it and no longer works, though I’m not sure when/where the change occurred.

Rather than returning an object in JSON, runtest.php now returns the object in JSON but as if passed into a function: callback(object).

This form of URL:***&

Returns this form of response:{"statusCode":200,"statusText":"Ok","data":{"testId":"***","ownerKey":"***","jsonUrl":"http:\/\/\/results.php?test=***&f=json","xmlUrl":"http:\/\/\/xmlResult\/***\/","userUrl":"http:\/\/\/result\/***\/","summaryCSV":"http:\/\/\/result\/***\/page_data.csv","detailCSV":"http:\/\/\/result\/***\/requests.csv"}});

It used to return just the object:


Is this new behavior expected? Thanks.

Argh, sorry. Most of the code suported JSON and JSONP where JSONP would be used if a callback parameter was specified. I was cleaning up the JSON support across the different API’s and didn’t catch the parameter collision.

Since “callback” is used pretty heavily for JSONP (and particularly for HAR’s and the har viewer) would you mind using “pingback” instead of “callback” for the URL? I just pushed the code to production and it should resolve the issue.