Issue with Test History on Private Instance


I’m having two issues loading the history of my recent tests in my private instance after upgrading to 3.0.

When I click Test History I only see the last test I ran, and it’s incomplete.


I have tried toggling the “Show tests from all users” as well as the “Do not limit…” options but I only see the last test I ran.

The second issue is that even with the last test, it doesn’t have a URL next to it (there is no option to click the test URL).

I checked with the previous version on a separate WPT private instance and the issue doesn’t exist - it works perfectly and as expected.

If I go to the results directory, i can see all the tests (in my case /results/17/01/24/…) so I’m confident they are being stored properly.

Any suggestions on how to have them show via testlog.php?

Attached is a screenshot of the issue.

Hi All,

Quick update (and this closes this issue), I was able to correct this by installing additional PHP7.0 modules. I’m not sure which one fixed it however (I think it was php-gettext).

In my case, to correct it, i reinstalled PHP7.0 by running this command:

apt-get install php7.0-mysql php7.0-zip php7.0-curl php7.0-gd php7.0-intl php-pear php-imagick php7.0-imap php7.0-mcrypt php-memcache php7.0-pspell php7.0-recode php7.0-sqlite3 php7.0-tidy php7.0-xmlrpc php7.0-xsl php7.0-mbstring php-gettext php-apcu

Hi All,

I found the root cause, you can fix this issue by installing the php7.0-mbstring module.


apt-get install php7.0-mbstring

Installing those dependencies solved a mysterious problem where tests were completing on the client but would never complete on the server. Thanks!

I had the same problem.
amars86’s solution worked for me.

Had same problem as this last week, however, this solution didn’t work for me:(

If you have empty history or new tests doesn’t appear in test history: check file permissions for /logs directory. It should contain test logs for every test day. If you don’t have this log files - fix permissions.