Problem with Instance AMI (EC2)

Hello how are you?

We annoying, because I’m trying to raise private WPT using EC2 instance, on time this AMI: webpagetest/Server at master · WPO-Foundation/webpagetest · GitHub

So far I could lift smoothly, I can access by UI too, but when I throw a test does not start (is always in “Waiting”).

I commented a bit what you play on the instance, in the settings.ini file:

  • Add the line ec2_key = xxxxxxxxxx
  • Add the line ec2_secret = xxxxxxxxxxxxxxx
  • Add the line headless = 0

Also in configure EC2 instance in a group with access to ssh (20) and http (80)

In logs EC2 instance I see this message that maybe helps to better understand the problem …
“PHP Warning: file_get_contents( failed to open stream: HTTP request failed! HTTP/1.0 404 Not Found in /var/www/webpagetest/www/cli/ec2init.php on line 91”

You should be able to ignore the user-data warning (I’m assuming you didn’t provide user data when starting the instance since you edited the settings by hand).

Does the EC2 key have permissions to start and terminate instances? That would be the first thing I’d recommend checking.

Thank you! It worked perfect now! It was a permissions issue with the user EC2 …

Take this opportunity to make another query, I worked far from the UI, but what I want to do is automate and by api (using this the problem that I have is not as generating api key that I should tell you … I saw that in settings.ini, the key “api_key” but do not know what value should put, any ideas?

Again, thank you very much for the help!

If you didn’t pass an API key through the user data then one will be automatically generated (random). You can see what the generated key was or generate your own additional keys in settings/keys.ini

The generated API key will be the value in with the description=API Key