setCookie not working any more

Hi, I was using the ‘setCookie’ property to bypass a cookiewall on my tests, and it stopped working a few days ago. I didn’t change anything, I think some change was introduced on the server, seeing the recent github commits.

It stopped working around 4th april 14h GMT.
I’m using Amsterdam, NL - IISpeed - Firefox - Native

Thanks !

I think i may be suffering from this too … i ran a script about a month ago which had a ‘setCookie’ command and it worked but the same script doesn’t work right now …
I’m using a private instance with agents running on version 371 (same as public wpt agents)
Note: I tried both Chrome and Firefox - same issue

Yeah, I think is a bug introduced on the latest release. Let’s just wait for Patrick to take a look :slight_smile:

This issue appears to have been raised as a bug on the WPO github: https://github.com/WPO-Foundation/webpagetest/issues/844

Hi, I just discovered that the problem is happening only in Firefox. Here are two exact tests with scripting, setting a cookie to remove the cookie bar (on the top of the screenshot):

I see something different, though, if I use the API (npm), but it also fails. I think this functionality needs to be reviewed with the update.

Thanks