setDNSName is not working in the script

Hi all,

I have run some tests today by the following script (all site names and CNAME changed)


But setDNSName command was not used, because I could see the site to be loaded from the real origin. I have been running similar tests using the script many times before and all was OK. But now it is not working with all the sites I’ve tried. I have even tried to enter the setDNSname to the non-existing CNAME, and I still would get a normal page from the origin.
If I open some of my old tests using the links I have saved and re-run the test with the same settings, it works and I get the page over the proxy I specify with setdnsname.

Development team, have you been changing something with scripting? I would be very grateful, if you could take a look at this issue ASAP.
I have tried using setDns to specify the IP address of the proxy server, and it works OK. But it is not suitable for me, because I need the CNAME record to be used.



Try reversing the order, you need to set the DNS name before doing the navigation.


I’ve tried it - same result, does not work either. Actually it was working OK during my earlier tests. Maybe has released a new version? I see there is some Pagespeed information being shown…



Do you have links to both a working and failed test? I can compare the scripts and see what is different. You also need to make sure the script is tab-delimited.

I have rewrote the script with tabs instead of spaces and now everything works OK! I guess I have accidentally added some spaces instead of tabs when modifying scripts.

Thank you very much!