testing with IE 10 hangs

no idea what is occuring.
I don’t have access to pc with IE 10 for testing.

using webpagetest with IE 10 setting on greenspotantiques.com just hangs, give no output, after about 3 minutes, declares no result.

Is my html to blame?
(all other browsers work fine on my machines, and on webpagetest.org).

FWIW I am seeing the same thing on www.etsy.com - IE10 doesn’t work.

Maybe an intermittent issue? - http://www.webpagetest.org/result/130304_GE_762710f50075772e645dbe9848dfe8ee/ and http://www.webpagetest.org/result/130304_KT_681dc49eed351b8ea5def97efb3a8898/

The HTML wouldn’t be to blame - you would get a test timeout and data back. It’s going to be an agent issue (ok, bug).

Could also have been fixed with an agent update but I didn’t do anything specific for IE 10 recently so it would have been an accidental fix.

I’m having a similar problem with my VMs, Windows Server 2008 R2 64-bit, has IE10 installed.

I’m using 2.10 server and agents.

When I issue an IE10 test, the agent picks it up, and the server reports “The test completed but there were no successful results.” right after the agent picks up the request, and BEFORE the agent loads the page. If RDC’d into the agent, I can see the page load in the agent. From watching the agent, you couldn’t tell anything is wrong.

It does this everytime. Every request turns into a “The test completed but there were no successful results.”

Chrome and Firefox work fine under wptdriver.

If I add “browserExe=pagetest.exe” to my location on the server, everything works fine, except now it appears as IE9. c:\webpagetest\pagetest.exe issues a user-agent of “Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/6.0)”

Should I just ignore this problem and let pagetest.exe run as IE9? Is it really IE9, or is it IE10 with an IE9 user-agent header?

Try using wptdriver for the IE 10 testing instead of urlblast. Urlblast misses the DNS and socket connect times from IE 10 (when it works) because of changes to IE. Wptdriver does a lot better with it and is what I use for the public IE 10 agents in Dulles (though those are on 32-bit Windows 8).

I’m actually looking into 64-bit server 2008 R2 with IE 10 right now because wptdriver was crashing for me on another deployment so there’s a chance that it won’t work there either (yet anyway).

That worked.

Had to make locations.ini and wptdriver.ini match.

locations.ini (on the server):
label=“US Phoenix - Wptdriver”

wptdirver.ini (on the agent), added:

exe=“C:\Program Files\Internet Explorer\iexplore.exe”

Turned off UrlBlast, rebooted, and now it all works. Thanks Pat!

This solution worked for me as well with Windows 8 IE10.

Also worked for me - Win 8 x64 / IE10