what's the holdup to render on this?

not sure what’s up.
I’ve been able to get a decent TTFB speed out of my local server here… and had better render times in previous tests.

lately I’ve added pinterest buttons here… and am curious.
is the holdup to render page the pinterest js → html load?

page test at

any tips appreciated.
I had the render time down to about 1.5 seconds earlier.
(yes, slow, but it’s off an office imac on dsl)

Your webserver is located in canada, and you are doing a test from ashville North Carolina. That is a reason for you TTFB to take so long to connect.

No, I don’t think the server location is the issue.
I’m not overly concerned with TTFB, as I am with the time to render page. :huh:

in previous tests the time to render was much quicker.

There seems to be a hang now, that was not there before.
test from chicago.
test from los angeles

in both tests, the pinterest links seem to be the point where the page starts to “render”.

Previously, the page rendered quickly in comparison.

also note the long times to the api.pinterest… count.json links.

from what I can see, you are loading http://assets.pinterest.com/js/pinit.js twice, try removing one of them

no, I don’t think so… checked all the tests, the pinterest js is called only once.

I’ll note that in past, I used to see the page render at around request
#11 of the page… now it’s at request number #29 .
I’ve disabled the pinterest calls… and I still see the same .

So it must be one of the css or js files blocking render?
hmm. might have caught it.

disabled the pinterest links.

disabled the google analytics code (funny, it’s set to be async)…
Get this result 1.629s to render

re-enable google analytics get this. 1.848 secs to render

even though the ga .js file takes only 64 ms to load… it seems to create a lag before next request.

reinstalled the pinterest links, and sure enough, the culprit is the google analytics.
with pinterest back on, and ga off, I get render at 1.629s

therefore pinterest does not seem to be creating the slowdown, google is.

sure enough, re-enable the google analytics code and the render time is back up to 2.059s


disable it, and it’s back to 1.74s

funny that google analytics would cost me from .3 to .5 seconds, must be a conflict with other stuff.

anyone else see this before?

I loaded your page in my chrome browser and looked at the source. Look at the bottom, you will see that http://assets.pinterest.com/js/pinit.js is loading twice.

you should put your css files call above all JS calls in the

if anything, i would load the pinterest after onload or at least in asynchronous mode.
this post seems to solve that issue:

Let me know how it goes

Also make sure to do a lot of runs if you are trying to measure differences of 100-200ms. That can easily be in the noise for individual test runs.

I’ll follow your notes… thanks.

for now, simply putting the google analytics at the bottom seems to help with overall render.
I’ll get your other points done… and let you know.

I found the duplicate pinit.js thanks.
due to some optimizers, I don’t have complete control of locations of css js files, but most are in best locations.

I tried the blog post asynchronous mode for pinterest… works great. pushes the pinterest calls further down the page, after point of render.

Thanks, I think that’s as good as it gets :slight_smile:


thanks muchly.
Vincee. [hr]

thanks, Patrick… yes been running a lot … and thanks for the great tool… helped me catch these minor faults today, as other days.

I never fail to be amazed at your tool here :idea:

Vincej :heart:

glad i could help,