WPT2.5 - URLBlast runs but doesn't start new jobs

Hi! I apologize if I just missed something, but after hunting around for information enough time I’m embarrassed to admit exactly how long, I’m still not sure what the problem is.

I’ve got a WPT server set up without any troubles [relevant ini files pasted at the bottom], or at least as far as I can tell :stuck_out_tongue: I am able to hit the getwork.php? file manually and view any jobs created.

I am having trouble setting up a WPT test client, though. I’m running Windows Server 2008 [32-bit], hosted on EC2. I’m not using the provided images because, frankly, I’m curious and wanted to learn more about the system :smiley: I followed the instructions on the Private Instances wiki page as best I could [skipping DummyNet]. In theory, it should be set up to run IE9.

Currently, URLBlast does start running, but nothing seems to happen. Checking the jobs folder on the server shows there is a job waiting to be picked up, but the test client never reaches out to it. No requests are made at all [verified by checking the httpd logs on the server]. Any information as to what could be holding things up would be amazing. On the client side, I’m really not even sure if I’m putting files in the right locations in the first place @_@ I’m more of a UNIX than a Windows guy :stuck_out_tongue: Thanks!


= locations.ini
[font=Courier] 1 [locations]
2 1=ec2-ca
3 default=ec2-ca
5 ; Physical Locations
6 [ec2-ca]
7 1=ec2-ca-ie9
8 label=Northern CA, USA
9 lat=34.057552
10 lng=-118.240585
11 key=937845099
13 ; The individual configurations
14 [ec2-ca-ie9]
15 browser=IE 9
16 connection=LAN
17 label=“Northern CA - IE 9
18 localDir=/var/www/html/work/jobs/ec2-ca
19 key=937845099[/font]

= connectivity.ini
[font=Courier] 1 [LAN]
2 label=“LAN”
3 bwIn=100000000
4 bwOut=20000000
5 latency=0
6 plr=0[/font]


= urlBlast.ini [located in the same folder as the urlBlast exe, not the startup shortcut]
Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
use current account=1

; Where to get work from
Url Files Url=http://my-ip/work/
Location Key=937845099[/font]

= wptdriver.ini [located in the same folder as the urlBlast and wptdriver exe’s]

exe="“C:\Documents and Settings\Administrator\Local Settings\Application Data\Google\Chrome\Application\chrome.exe”"
options=’–load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --new-window --no-proxy-server --no-first-run --no-default-browser-check --enable-experimental-extension-apis’

exe=“C:\Program Files\Mozilla Firefox\firefox.exe”
options=’-profile “%PROFILE%” -no-remote’

The agent needs to be configured with the leaf node location. ec2-ca-ie9 in this case, not ec2-ca.

Hi! Thanks for the quick response. I made the change, but I still get nothing [no requests to getwork.php? in the server log]. I looked at the urlBlast log and saw the following:

[font=Courier]2011/12/16 18:46:13 -1 0 1 0 0 URLBlast Started
2011/12/16 18:46:13 -1 0 1 4 0 CPU String Intel(R) Xeon(R) CPU E5410 @ 2.33GHz
2011/12/16 18:46:13 -1 0 1 5 2419 CPU MHz
2011/12/16 18:46:13 -1 0 1 6 1738 Total RAM (MB)
2011/12/16 18:46:13 -1 0 1 7 30717 Disk Size (MB)
2011/12/16 18:46:13 -1 0 1 8 18174 Disk Free (MB)
2011/12/16 18:46:13 -1 0 1 9 6 OS Version Windows Server 2008 Service Pack 2 (6.0.6002 SP 2.0 Suite 0x00000190 Product 3)
2011/12/16 18:46:13 -1 0 1 10 0 Computer Name IP-0AA0433F
2011/12/16 18:46:13 -1 0 1 19 0 Info Screen: 1024 x 768 - 24 bpp
2011/12/16 18:46:13 -1 0 1 11 9 IE Version 9.0.8112.16421
2011/12/16 18:46:13 -1 0 1 12 304 URLBlast Version[/font]

For curiosity’s sake, I VNC’d into the machine and restarted URLBlast manually. After it goes through the set up phase, a command prompt pops up, displays a bunch of information, then disappears before I can read it or copy anything. I think I saw the words socket and dummy net, but I’m really not sure. It pops up incredibly fast, and I’m not familiar with how to save the output from a cmd prompt that spawned from an exe and disappears quickly.

Either way, what I think I saw begs the question: if I’m not running DummyNet, is there anything I need to do aside from what is specified in the config in my first post? If DummyNet is [theoretically] set up properly, is there anything else that could cause the lack of behavior I’m seeing?

Thanks again for your help!

you can enable some debug logging which should help. Just add “debug=1” to urlblast.ini and restart urlblast.

Already done [see the urlblast.ini in the first post]. Is it possible it’s not picking up that config file in the first place?

Is UAC disabled? I think I’ve seen a similar patern before when it wasn’t. Otherwise I’d expect to see a lot more in the log.

It’s disabled. Sorry to be so difficult – I’m [obviously] stumped. I do appreciate the help, though.

Point of interest: in the urlBlast.ini file, I specify Log File=c:\webpagetest\urlblast, but the actual urlBlast log shows up under c:\urlBlast_log

Is that Log File config option not for the same log, or is that significant? Thanks again!

is urlblast.ini in the same directory as urlblast.exe and does the user account that urlblast.exe is running under have permission to read it? Is it also not open in an editor somewhere?

That looks a lot like a default setting from not being able to access the file.

Yep! Within the C:\webpagetestdir are urlBlast.exe and urlBlast.ini. Are they case-sensitive?

I checked the permissions, and the groups SYSTEM, Administrators, and Users all have [at the least] read and execute permissions. Do they need any other permissions to run?

no, not case sensitive. The user needs to be able to write to the directory where the log files are. I may have to whip up a custom build that does a lot more logging to see what is going on.

I double checked and gave SYSTEM, Administrators, and Users all full control over the c:\webpagetest folder / subfolders. Still no luck :frowning: