dummynet on windows 8 64bit

I’ve got webpagetest running on windows7 64bit but when I try the same setup on windows8 I can’t get the dummynet ipfw.cmd to work. Each step says "my_socket failed 5, cannot talk to kernel module. ipfw: socket: No error’

I installed the 64bit netwrok service and used the 64bit dummynet files under c:\webpagetest\agent\dummynet, just as with windows7.


Just as a sanity check, are you running the ipfw.cmd in a shell that has administrator rights? Did you also put the machine into test mode and reboot before installing the driver?

I have it running in 32-bit Windows 8 and 64-bit Server 2008 R2 and 64-bit Server 2012 but I don’t think I’ve tried a 64-bit Windows 8 yet so I’ll also see if I can reproduce it.

I started a command prompt as administrator and ipfw appeared to run ok. (I think windows8 is more locked down, I am an administrator on the box, and didn’t need to do this on windows7)
But when I run a test, urlblast says it has completed the urls but the report is empty. Maybe I have to install the driver in test mode (which I didn’t do before). I didn’t get any error messages though… So, how do you put windows8 into test mode? I did find this:


but not sure if I should trust it? Is there another way? I am running over remote desktop…

I tried using Chrome. Launching IE on the same box (having closed urlblast). I got a message box saying chrome had crashed but left it alone. The test ran but IE also crashed. I brought IE back up and the test had run but I only got a good result from the repeat view. the first view had missing data.

I am generally finding windows 8 a pain so I wouldn’t put this as a priority. I haven’t fully switched yet…
Firefox from IE worked. But again IE crashed. But bringing back IE and restoring the session gave a full webPageTest result with both views. I guess this means the network driver is installed ok (without using test mode). Chrome and IE both seem to have problems then on windows 8.
Latest update: it looks like I can use Chrome and Firefox for testing if I spark up the test run from an external box. IE still isn’t happy even with this setup.
Chrome doesn’t appear as stable as Firefox. The Chrome windows sometimes stays open after the first view test has come back as completed. For the moment it looks like Firefox is the best bet.

Yeah, I’m not liking Win 8 for automation, mostly because of the difficulty in getting it to auto login to the desktop and auto-launch wptdriver/urlblast.

I’m going to be poking around the 64-bit Win8/Server 2008 R2 issues next week to see if there is something funky going on. 32-bit works fine (I’m running 4 Win 8 VM’s in Dulles) but I haven’t played with 64-bit.

I’ve also discovered that the ipfw+dummynet network service stops my wake-on-lan working with windows8. Normally I can wake on lan with a magic packet if I hibernate windows8. But with this service installed, that doesn’t work. Don’t know if there’s anything you can do about that. Windows8 wake on lan seems to be a pain at the best of times.