Unable to install/setup webpagetest

I am unable to install/setup webpagetest on my windows 7 machine. First I was not able to install the dummynet driver at all, when I browse the installation directory where netipfw.inf is, it gives me “unable to find any drivers for this device”, so I ignored the dummynet and configured my apache to “Web Page/Content” directory, with that I am getting the webpage test home page. I was so happy, but when I try to submit a test, it is stuck at “Testing…” page and not actually performing any test. When I check the logs, I saw the error "Error Failed to create user account ‘user1’ " and Error Logon failed for ‘user1’. Any help from any one will be highly appreciated. Below is my web page test log file.

764	1	0	0	URLBlast Started	
764	1	4	0	CPU String	Intel(R) Xeon(R) CPU           W3520  @ 2.67GHz
764	1	5	2666	CPU MHz	
764	1	6	4093	Total RAM (MB)	
764	1	7	49999	Disk Size (MB)	
764	1	8	12895	Disk Free (MB)	
764	1	9	6	OS Version	Windows Vista (6.1.7600  SP 0.0  Suite 0x00000100  Product 1)
764	1	10	0	Computer Name	MyUserName
764	1	11	8	IE Version	8.0.7600.16385
764	1	12	234	URLBlast Version
764	1	18	0	Error	Failed to create user account 'user1'
764	1	18	0	Error	Logon failed for 'user1'

Thanks in advance.

I expect your dummynet problem is because you’re running on 64-bit windows which isn’t currently supported for dummynet. You’ll still be able to do testing but you won’t be able to simulate different connectivity types (and you’ll need to tweak your locations.ini).

Are you running UrlBlast under an admin account? It needs to be able to manipulate the user account that the browser will run under. It’s possible that the account failed to create because of password policies or something like that. You can manually create the user account as “user1” with a password of “2dialit” (as a limited or guest user) to see if that gets things moving (you can also override the account name and password in urlblast.ini if you need to use different credentials for the test account).

Pat, Thank you so much for your assistance. I have made little progress with your instructions, I have added my user credentials into urlblast.ini and it actually showed me the test result page, but everything is empty including the waterfall diagrams.

Load Time 	First Byte 	Start Render 	Time 	Requests 	Bytes In 	Time 	Requests 	Bytes In

First View 0.000s 0.000s 0.000s 0.000s 0 0 KB 0.000s 0 0 KB

This time, URLBlast actually says its running, and shows rebooting in 655 mins and also the cpu usage, but for some reason it is not actually performing the test. Is that in anyway depends on the “ipfw.cmd”, when I try to start ipfw.cmd manually I am getting some socket failed errors like below

C:\Web Site\dummynet>ipfw.cmd

C:\Web Site\dummynet>set CYGWIN=nodosfilewarning

C:\Web Site\dummynet>ipfw -q flush
my_socket failed 2, cannot talk to kernel module
ipfw: socket

C:\Web Site\dummynet>ipfw -q pipe flush
my_socket failed 2, cannot talk to kernel module
ipfw: socket

I have also attached a screenprint of my test results page here.

Thanks in advance.

In your settings/locations.ini add:


To the same section that has the workdir defined. That will disable using dummynet.

Thank you so much Patrick for your great support, I have able to setup in my machine successfully. This product simply rocks.

I have a similar problem but I’m on a 32-bit.

I’ve enabled debug in URL blast and see after every log ok the following.

Work request response was empty