WebPagetest 2.9

Get it before the world ends! - https://sites.google.com/a/webpagetest.org/docs/private-instances/releases/webpagetest-2-9

The biggest changes/improvements:

  • Traffic-shaping support for 64-bit windows
  • IE 10 Support
  • Safari (Windows) Support
  • Improved SSL reporting for Chrome

I’ve downloaded the latest WebPAgetest 2.9 today and i tried to install on WAMP. I followed the configuration settings listed on andy’s blog - http://andydavies.me/blog/2012/09/18/how-to-create-an-all-in-one-webpagetest-private-instance/. In the last step “Test agent configuration”, I installed Dummynet+cfw for my 64 bit OS successfully but after i restarted the system (remotely) and urlBlast, webdriver, cfw started as start-up scripts my remote computer froze. urlBlast window went to not responding mode and i lost remote desktop connection. I was not able to connect again until somebody removed this installation and reverted to the previous one using XAMPP. I’m still not able to understand what happened there :huh:

Given below are my configurations. Please let me know if there is any problem in my configuration.

Location.ini

[locations]
1=Local
;2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local
connectivity=LAN

;[Public_Dulles]
;1=WPT_Dulles_IE8
;label=“WebPagetest.org - Dulles, VA”

;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

[Local-URLBlast]
browser=IE 9
latency=0
label=“Local - IE 9”
;browserExe=pagetest.exe
key=TestKey123
connectivity=LAN

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Local-WPTDriver]
browser=Chrome,Firefox
label=“Local”
connectivity=LAN

;
; This is an exaple of a “remote” configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
;
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
;
; To use the public webpagetest.org instance you will need an API key
;

;[WPT_Dulles_IE8]
;browser=IE 8
;label=“WebPagetest.org Dulles, VA - IE8”
; relayServer=“http://www.webpagetest.org/
; relayKey=
; relayLocation=Dulles_IE8

urlBlast.ini

[Configuration]
Startup Delay=30
Log File=C:\wamp\webpagetest\agent\urlblast
debug=1
Timeout=120
use current account=1

; Where to get work from
Url Files Url=http://127.0.0.1/work/
Location=Local-URLBlast
Location Key=TestKey123

wptDriver.ini

[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=Chrome
;key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
software=http://www.webpagetest.org/installers/software.dat

[Chrome]
exe=“C:\Program Files\Google\Chrome\Application\chrome.exe”
options=’–load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server’
installer=http://www.webpagetest.org/installers/browsers/chrome.dat

[Firefox]
exe=“C:\Program Files\Mozilla Firefox\firefox.exe”
options=’-profile “%PROFILE%” -no-remote’
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox

[Safari]
exe="%PROGRAM_FILES%\Safari\Safari.exe"

Regards,
Vivek

Did you run the testmode.cmd shell script before installing the dummynet driver? Without that Windows’ networking will stop working when you reboot which is a real pain on a remote system.

No i didn’t. Thanks for telling me that :D. But somehow even without using Dummynet+ipfw (As i removed it coz of the problem it had with remote connection), i was able to receive urls to test from the client machines. I was happy alright but a little confused too :huh:

Ok. I’ve successfully installed WPT Monitor on my system. I’ve also created a document which could help others to configure WPT Private instance and WPT Monitor on their system, so i’m sharing it here. Hope it helps other seekers.

~Vivek

Hi Patrick,

I’m having trouble running the web page test on Firefox and IE. When i pass the URL from the WPT private instance, it opens a blank page with no visible URL on IE but just “about:blank” and “http://127.0.0.1:8888/blank.html” on Firefox and doesn’t navigate to the entered URL :huh:. Its working fine for Chrome. Can you share your thoughts on this.

NB:The firefox version i’m using is 18.0 and Internet Explorer version is IE9

Thanks,
Vivek
[hr]
One more anomaly which i observed was the folder %profile% gets automatically created inside “agent” folder where as when it was working ok, it was located inside ~/users//%profile%.

Still when i run - %profile%, the ~/users//%profile% folder opens. When i remove ~/agent/%profile%, it automatically gets created again.

Hope this info helps in identifying the problem.

~Vivek

Ok, i found that WptBHO class and CIEHook Object was disabled on IE. Now its working for IE but i’m facing same problem for Firefox. Cannot find any class except for java console in its extension. Is there a work around to enable that extension for firefox as well or the methodology is different there??

~Vivek

Did you update the wptdriver agent by any chance? - http://www.webpagetest.org/forums/showthread.php?tid=11972

Firefox 18 broke one of the interfaces we were using so I had to release an update.

I’ve updated the agent folder with the files given on the link provided but still it didn’t workout :frowning:
So i downgraded the firefox version from 18 to 11. Still facing the same problem :frowning: :frowning:

Hi Patrick,

The Firefox simply opens - “http://127.0.0.1:8888/blank.html” (as shown in the attachment - Firefox_Blank.jpg) and does nothing. I’ve attached the screenshots of the WPT Private instance for reference. Please find them attached. Please let me know your thoughts on this.

Thanks,
Vivek

You need to update the test agent: http://www.webpagetest.org/forums/showthread.php?tid=11972

I’ll be releasing a 2.10 release this week as well which will include the updated agents.

Yes, i’ve applied the updates but it has no effect on Firefox 19… I’ll wait for 2.10 release then…

Are you sure the updates stuck (i.e. you put them in the server update directory so the agents didn’t revert)? Only reason I ask is that Firefox 19 is working with the current agent code: http://www.webpagetest.org/result/130226_1R_KS4/ and the update process grabs the same code I’m running on the public test agents.

Well… yes as far as i know :frowning:
Given below are the steps i followed:
I took the latest updates from here - https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-Updating-Test-Agents . Then i unzipped the wptupdate.ini & update.ini files and placed it inside the ~/www/work/update folder (please find the screenshot attached) and also copied the zipped wptupdate and update files onto the same folder. Is there anything else i should be doing ??

No, that should be all that is necessary.

Thanks for the new release Patrick. But my problem still persists. Looks like its my system specific issue. Can you think of any alternative reasons as to why this could happen, for instance the wpt extension for firefox not working or something similar ??

Thanks again for the new release!

Can you open the dev tools and look at the console output to see if there are any error messages from the extension?

Please find the error message as attached…

What does your wptdriver.ini look like? It looks like your Firefox instance may not be using the custom profile directory like it should be. That or it’s also possible that some other extension has wedged itself into your install (the chrome manifest message at the top).

The error at the end isn’t an issue, there’s no content in the blank page anyway.

So how do i fix this??

This is how my wptdriver.ini looks like:

[color=#FF0000]wptdriver.ini
--------------[/color]

[color=#9400D3][WebPagetest][/color]
[color=#0000CD]url=http://vsingh-win7.home.local
location=Local-WPTDriver
browser=Chrome
key=NewTest123[/color]
[color=#006400];Automatically install and update support software (Flash, Silverlight, etc)[/color]
[color=#0000CD]software=http://www.webpagetest.org/installers/software.dat[/color]

[color=#9400D3][Chrome][/color]
[color=#0000CD]exe=“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”
options=’–load-extension="%WPTDIR%\extension" --user-data-dir="%profile%" --no-proxy-server’
installer=http://www.webpagetest.org/installers/browsers/chrome.dat[/color]

[color=#9400D3][Firefox][/color]
[color=#0000CD]exe=“C:\Program Files (x86)\Mozilla Firefox\firefox.exe”
options=’-profile “%profile%” -no-remote’
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox[/color]

[color=#006400];[Safari]
;exe="%PROGRAM_FILES%\Safari\Safari.exe"[/color]