Error submitting url for testing

anyone have the same issue with “Error submitting url for testing” when I click start test…:huh:

What location are you trying to test from and what URL?

any location didn’t work

Here’s one I just submitted:

Do you have Javascript enabled?

yep. acutally I installed webpagetest locally and try running locally, it showing up Error submitting url for testing" when I click start test, when I click start test, sorry for confusion…

Check and make sure that the apache user account has write permissions to the work/jobs, results and tmp folders. You’ll get that error when it can’t write out either the job file (work/jobs/) or the folder for the test (results/…)

yep, after added permission, the error was changed, the error showing up 404, actually, the results folder should be under root, but return url is actuallyhttp://localhost/result/110513_JD_5/, so it showing up 404, is there any setting in config file

Posted in the other thread but I’ll put it here as well in case people miss the other response…

Make sure mod_rewrite is installed and working. You’ll get a 404 if it isn’t. The results/ requests are actually rewritten to results.php?test=

I am having similar rewrite issues. The results page returns a 404.

[code]Not Found

The requested URL /result/110525_T7_2979c8c6d03d8d34b00b440cfdef00cf/ was not found on this server.[/code]

Here is my rewrite log. - - [25/May/2011:16:27:44 +0000] [ec2/sid#7f67b2d5f700][rid#7f67b2ffc568/initial] (2) init rewrite engine with requested uri /runtest.php - - [25/May/2011:16:27:44 +0000] [ec2/sid#7f67b2d5f700][rid#7f67b2ffc568/initial] (1) pass through /runtest.php - - [25/May/2011:16:27:45 +0000] [ec2/sid#7f67b2d5f700][rid#7f67b2ffc568/initial] (2) init rewrite engine with requested uri /result/110525_T7_2979c8c6d03d8d34b00b440cfdef00cf/ - - [25/May/2011:16:27:45 +0000] [ec2/sid#7f67b2d5f700][rid#7f67b2ffc568/initial] (1) pass through /result/110525_T7_2979c8c6d03d8d34b00b440cfdef00cf/

Any help would be appreciated.
Sorry jumped the gun. This fixed my issue. The only thing being served out of this is webpagetest.

<Directory /var/www/html>
AllowOverride all
Order allow,deny
Allow from all

I have the same error but my rewrite is ok and the permissions are correct.

If I use the test location I don’t get the error but using the public one with API key I get the error?

Is there a log file where I can have more info on the error?

can you PM me or email me your locations.ini that you are using to relay to the public server? I assume it is a test location that you have configured to relay that is having issues, right?

same error facing in iphone real device

Is this still an issue? I have write permissions, agent is also connected. When using public location I get an “Error submitting url for testing”. When using local location, no issues to run the test. I have been working on this for a week now, please help. Thanks in advance.

What location on the public instance are you trying to submit to? Is it one where testing is allowed using the API key you are using (usually just Dulles desktop, Dulles Moto G4 and the EC2 locations)?

Can you post the location info from locations.ini (with the API key obscured)?