requested URL /result/110506_XA_H/ not found on server

pretty sure I have the server software installed ok and I went through the steps of installing the client drivers. I must admit I’m still a little confused on how this is supposed to work. In any case when I go to WEBPAGETEST private instance page I have 16 “Pending Tests” in the queue

Not Found
The requested URL /result/110506_XA_H/ was not found on this server.

Apache/2.2.16 (Ubuntu) Server at webpagetest.orianthi Port 80

Do you have mod_rewrite enabled? That won’t help with the pending tests but that would explain why you’re getting a 404 page for the results.

Another possibility might be user permissions on the server. Does the apache user have write permissions to all of the directories in step 4: ?

For the pending tests, is urlblast running on the test machine? Since the test machine is different from the server you also need to modify urlblast.ini and replace with the name/IP of the web server (and then re-start urlblast).

  1. Yes I have mode rewrite enabled to the best of my knowledge. I used a2enmod command on ubunutu 10.0.4 - that created a static link for:
    rewrite.load → …/mods-available/rewrite.load
    headers.load → …/mods-available/headers.load
    expires.load → …/mods-available/expires.load

made sure I restarted the web server: sudo /etc/init.d/apache2 restart

installed “gd” and “curl” for PHP and also installed ffmpeg

  1. As far as permissions, I noticed that the “results” folder did not exist in the archive but once I tried to run a test, it was created automatically and given the permissions 777 for www-data which is my Apache user. The “logs” folder did exist in the archive so when I gave it the permission of 777 (to let www-data have access) but I did not change ownership to www-data. Do I need to? Also the “tmp” folder did not exist in the archive but I created that folder and again gave it 777. And for work/jobs, there was no “jobs” folder in the “work” directory so I created that as well and gave it 777

  2. urlBlast.exe is running, I have a shortcut to it and ipfw.cmd in my Startup folder - as far as the configuration of urlBlast.ini, I do have the url pointing to my webserver - Location=Test and Location Key=Testkey123 - are those correct or do I need something different there?

Thank you


Can you check the access log and error logs on your apache server? The access log should have entries for “/work/getwork.php”, otherwise URLBlast can’t talk to it for some reason.

You might also have to enable the debug log in urlblast (add debug=1) and see if there is anything interesting in the urlblast log. I have seen it have a problem creating the test user account because of password complexity rules before.

Ok, so I ran the webpagetest while I tail -f error.log and access.log -

so access.log tells me that a POST request was initiated for the script /runtest.php - it also told me that a GET request was sent for /result/110509_MC_Q/

But there is no “/result/110509_MC_Q/” directory. In fact there is no “/result” directory. What happens is that when I runt the webpagetest, a “/results” directory gets created and inside of that is a “11” directory and so on. So the full patht that gets created is /results/11/05/09/MC/Q and then inside of there is where I see the testinfo.ini, testinfo.json.gz and url.txt files.

Also the Apache error.log file says “File does not exist: /home/fed_user/www/webpagetest/result” - so it’s looking for “result” but “results” is what is being created.

Also, would it be helpful to post my “sites-available” or vhost conf entry rather?

/result/X goes through a rewrite rule that ends up asking for result.php?test=X so it’s normal for that directory to not exist.

It doesn’t look like mod_rewrite is working. Your conf would probably help - if I had to guess I would say it was missing “AllowOverride All”

You should also be seeing requests for /work/getWork.php - otherwise urlblaster is not connecting to the server to retrieve the tasks for testing.

This is from my the sites-available folder in which I have a vhost file named “webpagetest”. I’m using Ubuntu Server 10.0.4

<VirtualHost *:80>

ServerName webpagetest.orianthi
DocumentRoot /home/fed_user/www/webpagetest

<Directory /home/fed_user/www/webpagetest>
	AllowOverride all
	Order allow,deny
	Allow from all

ErrorLog /home/fed_user/www/webpagetest/logs/error.log
LogLevel warn

CustomLog /home/fed_user/www/webpagetest/logs/access.log combined

I just noticed something in my urlBlas.ini file below. I don’t have “work” directory after my Url Files Url - I will change this and see what happens:

I am not getting requests for /work/getWork.php - my urlBlast.ini file looks like this:

Startup Delay=30
Log File=c:\Web Site\log\log

; Where to get work from
; Url Files Url=
Url Files Url=
Location Key=TestKey123

Yep, you need the /work/ on the end in your urlblast.ini (though I would have expected to see 404 requests to /getWork.php without it). Can you add a debug=1 to urlblast.ini, restart urlblast and grab the log file?

Thanks for the reply.

I did add /work/ to the end of my URL and nothing changed.

I added debug=1 to urlBlast.ini and restarted it by double clicking on the urBlast.exe - the little grey window came up and it sayed “Clearing caches…” - “Rate: N/A” - “CPU Usage: N/A”

and it just stays on that little screen… and hasn’t change for 30 min


also when I have debug=1 on, how do I see the output or logs or verbose output?


The log should be written where it is specified in urlblast.ini -

c:\Web Site\log\log_log.txt I believe



so access.log tells me that a POST request was initiated for the script /runtest.php - it also told me that a GET request was sent for /result/110509_MC_Q/

Solution …In Apache 2.4 and above remove multiview setting from apache configuration file.