GZIP doesn't work properly

Hi everyone,
I’ve a doubt that I want to share with you.
I’ve enabled gzip compression for the site www.aimgroupinternational.com, but when I check the web page speed, webpagetest.org says me that I need to enable it.
What’s the matter with this?
Can someone help me?

Try adding this

[code]# BEGIN Compress text files

AddOutputFilterByType DEFLATE text/html text/xml text/css text/plain
AddOutputFilterByType DEFLATE image/svg+xml application/xhtml+xml application/xml
AddOutputFilterByType DEFLATE application/rdf+xml application/rss+xml application/atom+xml
AddOutputFilterByType DEFLATE text/javascript application/javascript application/x-javascript application/json
AddOutputFilterByType DEFLATE application/x-font-ttf application/x-font-otf
AddOutputFilterByType DEFLATE font/truetype font/opentype

BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4.0[678] no-gzip
BrowserMatch bMSIE !no-gzip !gzip-only-text/html

END Compress text files ][/code]

From Ozzy at ozzmodz:

[quote]Gets me this result, WebPagetest Test Result - Dulles - 03/29/14 12:49:12

As you can see, it improved the First Byte Time from a D to a C and the Compress Transfer from a F to a A

Pretty decent gain, here is what is happening there:

Apache Module mod_deflate

When a user hits your website a call is made to your server to deliver the requested files.
The bigger these files are the longer it’s going to take for them to get to your browser and appear on the screen.
Gzip compresses your webpages and style sheets before sending them over to the browser. This drastically reduces transfer time since the files are much smaller.

The reason gzip works so well in a web environment is because CSS files, JS files and HTML files use a lot of repeated text and have loads of whitespace. Since gzip compresses common strings, this can reduce the size of pages and style sheets by up to 70%!

Gzip has to be enabled on your webserver which is relatively straight forward.
When a browser visits a webserver it checks to see if the server has gzip enabled and requests the webpage. If it’s enabled it receives the gzip file which is significantly smaller and if it isn’t, it still receives the page, only the uncompressed version which is much larger.[/quote]

Also: you will need to have two Apache modules loaded, you can verify by viewing the “Loaded Modules” under “apache2handler” configuration via phpinfo. Ensure mod_deflate and mod_headers modules are there.

If they are not there, you can either re-configure Apache to have them linked statically or load as DSO (Dynamic Shared Object).

Thanks avalanch for replying,
I’ve followed your suggestions, but nothing is changed!!
I’m frustrated!
Any other idea?
Thanks in advance.