IE sits at about:blank; log says "Timed out waiting for browser to start"

I assume I’ve misconfigured something, but what?

Not sure what other info I can post to help diagnose this. Here’s an excerpt from wptdriver.ini:

[IE 10]
exe=“C:\Program Files\Internet Explorer\iexplore.exe”

Go to tools->manage add-ons and make sure the WebPagetest BHO is enabled. Sometimes IE will prompt at the first launch after install to get it enabled and disables it by default.

Sorry, in case it wasn’t clear, that needs to be done inside IE.

Thanks for the quick reply, Pat. It was already enabled. What next?
Figured it out. My node has two IE’s installed: one in Program Files, and one in Program Files (x64). wptdriver.ini was pointing to the wrong one (the 32-bit one, which does not have the BHO installed). The fix was to point it to the 64-bit one.

Hmm, hopefully you have that reversed because the BHO is 32-bit code and will only work in the 32-bit browser.

It appears to work perfectly fine pointing the 64-bit browser. Are you sure the browser doesn’t have a way of loading the 32-bit BHOs?

Also, for future reference in this thread: this problem only seems to exist for IE<10. After that version, it appears that the 32- and 64-bit IE binaries actually share one set of BHOs between them, so it doesn’t matter where you install. Except for what Pat said above, of course ;-).

I’m still seeing the same issue. I have IE 11.0.9 installed on my system. IE just sits on the about:blank and closes. The webpagetest says - timed out waiting for browser to start

  • Which version of wptdriver.exe are you running?
  • What OS (version and 32/64-bitness)?
  • What path does wptdriver.ini point to for the IE exe?
  • Is IE enhanced security mode disabled (if running on server)?
  • What antivirus (if any)?

Hi Patrick,

-wptdriver.exe version

  • OS is Windows 7 64 bit

  • IE Path in wptdriver.ini
    exe=“C:\Program Files (x86)\Internet Explorer\iexplore.exe”

  • Not applicable - Not running on server

  • Antivirus on test agent – ESET Endpoint Antivirus 5.0

  • Webserver is Centos 6.4

And I keep seeing “No test agents are configured to render video” in the http:///install, even though the video rendering is working correctly.

Below is my location.ini for clarity:

label=“Test Location (Chrome, FF, IE)”

label=“Test Location”

Below is the wptdriver.ini

Time Limit=120
;Automatically install and update support software (Flash, Silverlight, etc)

exe=“C:\Program Files (x86)\Google\Chrome\Application\chrome.exe”
options=’–load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server’

exe=“C:\Program Files (x86)\Mozilla Firefox\firefox.exe”
options=’-profile “%PROFILE%” -no-remote’

;exe=“C:\Program Files (x86)\Safari\Safari.exe”

exe=“C:\Program Files (x86)\Internet Explorer\iexplore.exe”

Below is the Urlblast.ini
Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
use current account=1

; Where to get work from
Url Files Url=http:///work/
;Location Key=TestKey123

Sorry about the video thing - I moved rendering to the server but forgot to remove the install check (just fixed that).

Everything else looks right. Just as a sanity check, you are using wptdriver.exe and not urlblast.exe for IE testing, right?

One thing that comes to mind is that you might have to go into IE and enable the WebPagetest plugin. Just launch IE manually, go to manage add-ons and make sure it is enabled.

WptBHO extension is Enabled (32-bit)
CIEHook Object extension is Enabled (32-bit)

I’m only running wptdriver.exe at startup.

Combinations I have tried - (which may not be correct):

  • wptdriver.exe & urlblast.exe at startup, with urlblast.ini & wptdriver.ini
  • only wptdriver.exe at startup, with wptdriver.ini & urlblast.ini

I just wanted to update the thread with my issue.

When I downgraded IE11 to IE10, WPT worked fine. There is something definitely going on with IE11, which I’m not able to determine.

Any updates on this? For me too, IE 11 is the problem but our main target browser is IE 11

Have you tried the latest wptdriver (you shouldn’t use urlblast for IE 11 - it is deprecated and pretty crufty)? Here is the info on updating to the latest and greatest: