Installed Joomla 2.5 - All F's - Please help. Caching explained


Test Results:
I got all F’s except for Keep-alive Enabled, an A.

I have installed Joomla 2.5. It’s not live yet, still testing. It’s running very slow.

I have disabled Joomla Global Caching and enabled memcache. Only other thing enabled is the system cache plugin in joomla.

My site has over 50 articles daily, I cannot use the Joomla cache because the articles won’t be up on time.

I have JS CSS Control plugin to help reduce the Javascripts and CSS.

Any help would be great.


Do you have mod_deflate installed and active? That is the reason for your gzip F.

For the image compression, you have 2 jpeg images in your theme that should be compressed more: - Load them into a photo editor and save them with jpeg quality level 75 (if using Photoshop then it’s quality 50 in save-for-web).

You also need to modify your .htaccess (or use a plugin) to add expires headers to your static content (images, js, css, etc) - . This won’t impact the dynamic nature of your site but it will have a huge impact on the general performance of your site (and server load). If you search for “joomla expires header” you will get a bunch of results. This one looked reasonable - .htaccess File That FREAKIN Works! - The Joomla Community Magazine

That leaves the first byte time which is really painful at 4 seconds. That’s largely a function of the performance of your serving infrastructure (database in particular) and if you’re on shared hosting you are going to be suffering. You can make it better by enabling the global caching which will help hide the issue. I don’t understand why that would impact the articles not going up on time, when a new article is published it should invalidate the cache and re-build it.


Thanks for the reply. I have corrected the slow loading issue. But the First Byte time is still an F.

The First Byte time is 0.6ms, which is nothing I think. Here are the latest results:

Why is that?

The reason why I cannot use Global Joomla caching is because we post new articles every 10 minutes. I haven’t found a way to have those articles display unless we clear cache. If we don’t clear the cache, the we don’t see any new modifications on the main page.


Looks like you still need to install and configure mod_expires. This caches stuff in the client browser so they don’t have to re-load stuff - and that will mean that once css, jss, images etc are downloaded once, the site will speed up dramatically for the users.

Do you have an opcode cacher enabled? If not, look at installing eAccelerator.


Thanks for the reply.

I wanted to make sure it was a good idea to put the mod_expires in my .htacess? Reason I ask is because my website is a news driven website. The news articles are updated by the minute. We have over 50 new news updates per day.

To answer your second question, I have ACP installed. Using File caching option in Joomla and Global caching turned off.

Your HTML should not get cached with mod_expores but you should make sure your static content is. The css, javascript and images should not change every time you publish a new story.


I will try that and get back to you. Thanks.

Will my Google Adsense Javascript code get affected by this? I definitely cannot cache that.


I have enabled mod_expires on my server and added the tags in .htaccess.

I have optimized my images.

I still get an F for First Byte and a C for compress transfer.

Turn on compression for css and js

For TTFB you’ll need to look at what’s going on during page generation but it’s probably down to the efficiency of the DB queries - look for the slow queries in mysql

Thanks for the reply.

I already have a CSS/JS compressor plugin.

It helps a lot.

But the First Byte is still an F with 0.6 seconds, which I think is good.

Very strange.

Based on the results you’ve linked to

Compression of CSS and JS isn’t enabled, so I guess the compressor plugin isn’t doing it’s job correctly.

BTW I tend to configure this at the web server level rather than using plugins

I have resolved the compressed transfer. Got an A. I keep getting between A and B. It’s good.
I disabled two plugins.

The problem is with the First Byte and the Cache Static. Both Fs.
0.5s First Byte time. Isn’t that good?

Any help would be great on what to do.


I’d spend more time preparing images for the site, compressing them better. Mod_expires seems to be running fine - you’re caching all you’ve got control over.

Now you need to tune your server… opcode cacher, database configuration, maybe a swap to nginx / php-fpm???

Important info:

I finally got an A for First Byte, but not the right solution.

I have Joomla caching turned off and using APC caching. It’s slightly slow and it gives an F for First Byte.

**If I enable Joomla caching, it goes VERY FAST and I get an A.

The problem is, when I post news article, I cannot view them right away until the cache clears. I need to have my article show up right away, while using Joomla cahe or else I have to settle for APC caching.

That sort of implies that the Joomla! caching you’re using is pre-creating the pages in some way. I find it hard to understand that the inbuilt cache is incapable of automatically refreshing on content update (true!), or that there’s no way that you can manually refresh it as a last resort (Tools → Clean Cache).

According to the Joomla! docs, there are a number of engines that you can use… APC, Eaccelorator, File, Memcache, XCache. Which are you set up with?

I am using APC caching. That shows the updates instantly.

But if I use Joomla “File” caching, I need to clear cache to view updates. We cannot clear cache 50 times daily, it defeats the purpose of caching. I tried the cleancache addon that auto cleans on submission, but that’s not a good solution at all.

Yes you’re right, it’s hard to understand that the inbuilt cache is incapable of refreshing the content automatically.