Is WPTDriver needed for for wptagent in windows?

Hi there

So I am very confused as to how to setup local locations in a windows machine using the wpt-agent.

In the localhost/install the main and only error I get so far is Test Location

This is what I have working:

  1. Setup WAMP and replaced the www file with the one from the privateinstance zip file
  2. I have installed all the dependencies vs, python, php etc dependancies
  3. I converted the sample connections, settings and locations ini files to proper ini files
  4. I had the PUBLIC location to Dulles working when i added my api key to it, but since I only want local(OFFICE) chrome I removed it

I noticed in the locations.ini file it mentioned in the comments that for local chrome i needed to update the wptdriver.ini file

But that was no-where in the wpt-agent private instance zip.

Do I really need wptdriver to make this work?
and if so, where would I put the file and how would I configure it?

I am sorry, if what I am asking maybe simple and common sense to most here, but I was unable to figure this out after putting nearly 30 hours into this, and looking through the docs and google.

You need to install wptagent:

It works across all platforms and replaced wptdriver.

Thank you very much Patrick,

Got it done, and unfortunately later got stuck for too many hours, until I realized what you actually meant by having a batch file …as it was an example…

cd C:\wptagent call npm i -g lighthouse FOR /L %%x IN (1, 1, 24) DO ( git pull origin master python.exe C:\wptagent\ -vvvv --server "http://localhost/work/" --location "Test" )

Here is mine… And it make the whole thing run nice…


…after processing… a new problem arose

None of the tests are storing the results
At least in the links in TEST history show “NOT FOUND” “The requested URL was not found on this server.”

But when I go to the results folder in the server area, I can drill down to see theres a folder corresponding to each test with lots of gzips … but nothing like XML

I tried to see if I change the setting in settings.ini to NOT COMPRESS TO GZIP to 1
But the Agent would not process/detect the work when I did that, until I turned it back to 0

It’s possible that the friendly URLs aren’t working. If you go to http:///results.php?test= does it work?

The XML is generated on the fly from the raw test result data which is in all of those gzip files.

YES!! thats working
I can access the webpage on the browser
but the links on the page for raw or json arent working…

I am sorry… maybe you already mentioned it… but i didnt comprehend it… what url should I use to get the XML again?
or is the xml URL practically http://localhost/results.php?test=200512_VD_E (http:///results.php?test= )
Ignore that I was stupid…i should have just looked up the php files in the directory

for future reference for me and others who might learn from this…(and making this google searchable)
the direct file is

For Ex