Private Instance - Chrome - URL not loading when triggered with proxy

Hi

I am trying to invoke chrome with proxy. Earlier versions worked fine with the below command.

options=’–load-extension="%WPTDIR%\extension" --proxy-pac-url=“file://c:/Proxy/accelerated_pac_base.pac” --user-data-dir="%PROFILE%"’

But after updating the chrome and WPT, it is not working. Outside the network without proxy, it is working fine.
Please let me know, If I am missing something.

Try putting just the --proxy-pac-url option into a “command-line” setting. i.e:

command-line=’–proxy-pac-url=“file://c:/Proxy/accelerated_pac_base.pac”’

The options= setting was killed because it was too easy to break the user-data-dir and extension stuff, both of which aren’t optional.

Thanks Patrick…Now I am getting Failed to load extension from C:\Program Files (x86)\Google\Chrome SxS\Applications\56.0.2924.87%WPTDIR%\extension. Manifest file is missing or unreadable
[hr]

Thanks Patrick…Now it is working fine. Thank You for your support.

What was the exact resolution to get this working?

When I use the Chrome command line from the web under Advanced Settings:
–proxy-pac-url=file:///C:/webpagetest/config.pac

This works as expected. Any attempt to add this to the wptdriver.ini does not work. Oddly it opens a number of tabs where it appears to be getting script commands. However, the commands are getting treated as URLs.

wptdriver.ini
command-line=’–proxy-pac-url=“file:///C:/webpagetest/config.pac”’

My goal is to have this as default and not have to enter it for each test through the web ui.

I too stuck in the same issue, i.e., giving pac url as command-line in webdriver.ini file. it is not working but the same is working when provided from the web under advanced settings.

please suggest solution