S3 archving


Would you please confirm below settings are the only required ones for S3 archiving? For some reason, we don’t see the test results in the S3 bucket even though the AWS key have the proper permissions and confirmed that by running aws s3 cp command and setting the keys on the WPT server.


Also, where can I find the error logs on WPT server?

Hey there -

Good questions. All those s3 entries look good, but keep in mind your agents need to be polling for work in order for the archiving to kick off. If they aren’t (ie, if you only spin up instances as you need them), then you’ll need this entry as well to have it run hourly:


Good question about the error log, that should give you a detailed error message if that’s the case. By default it’s in: /var/www/webpagetest/www/log

Thanks for your answers.

I already sent tests to be executed and they were complete. Also, I looked at the log dir and no files there after completing the tests.

Should I look somewhere else or try something different?
Also tried the archive_dir but no luck and restarted nginx

I tried to issue GET /cli/archive.php. And got

Arc:0, Del:0, Kept:0, Checking:180608_0F_6
Arc:0, Del:0, Kept:1, Checking:180608_2K_C
Arc:0, Del:0, Kept:2, Checking:180608_B5_5
Arc:0, Del:0, Kept:3, Checking:180608_B6_9
Arc:0, Del:0, Kept:4, Checking:180608_BN_8
Arc:0, Del:0, Kept:5, Checking:180608_BW_D
Arc:0, Del:0, Kept:6, Checking:180608_FC_3

But no files exist in S3, archive_dir, or the logs.

Finally made it working by adding below to the settings.ini since we are protecting our instance inbound traffic: