Steps to be followed for archiving data to s3

So i did a local setup of wpt using docker and able to test the result , but i wanted test the archive process in wpt

Can anyone explain what all steps need to done.

Steps what i have done is

  1. In settings.ini made changes for these

    but nothing happened after this also
    I tried this command inside /var/www/html/cli

php archive.php

and output is arc=0 kept=no of tests rm=0

and i checked archive.log there nothing found.
Can anyone help in this and also what steps should be taken in s3 bucket creation process?

hi @tkadlec,
So basically I started installing the WPT server and agents using docker image version webpagetest/server:21.07 and webpagetest/agent respectively .

I ran a few tests it was working fine and I could see the result in history tab.
Then tried archiving the results to s3 using the following steps.

changed these settings in settings.ini

then I waited for one hour to see the data in s3 but there was nothing in s3.

i check the logs in /var/log/supervisor
cat cron_stderr.log and cat cron_stdout.log
I saw below mentioned error

Warning: scandir(./results/relay): failed to open dir: No such file or directory in /var/www/html/cli/archive.php on line 144

Warning: scandir(): (errno 2): No such file or directory in /var/www/html/cli/archive.php on line 144

Warning: parse_ini_file(/var/www/html/cli/settings/keys.ini): failed to open stream: No such file or directory in /var/www/html/cli/archive.php on line 150

Warning: Invalid argument supplied for foreach() in /var/www/html/cli/archive.php on line 151

Then I edited the archive.php to this


include_once "./";
include_once  "./";

i edited to this

include_once "/var/www/html/";
include_once  "/var/www/html/";

after all this everything was, again I waited for 1 hour and found this log

Arc:0, Del:0, Kept:19, Checking:220115_ZC_M

So i tried manually run the archive.php file
using this command

php archive.php

i got this message

Warning: S3::putObject(): [InvalidRequest] The authorization mechanism you have provided is not supported. Please use AWS4-HMAC-SHA256

please help in this.