Some locations do not work using the API


I open this post in part to see if someone else happens or is just me. The thing is that inrento make requests with the location ‘Spain’, but from the API returns this error:

{statusCode: 400,
‘Invalid Location, please try submitting your test request again.’ }

When yesterday I worked perfectly. The same thing happens with Paris and a few others, however there are other locations that work (but do not offer me the reliability of the data I’m looking for).

Can someone solve / clarify why this happens to me?

Thank you very much and greetings!:smiley:

AFAIK only Dulles, London and the Akamai sponsored locations support API requests

(there might be more but it’s generally up to a locations sponsor as to whether it’s enabled)

I have the same issue with “Stockholm2”
It worked for weeks and few days, all of a sudden, it’s stopped working.

It would be nice to have more information of which locations can be used with API.
AFAIK there is nothing in the location API response to understand if a specific location can be used via API or not

Hello andydavies,

I appreciate your answer but what you say does not make sense since the location of Spain (La Rioja), worked perfectly until the other day that did not let me make requests.

The question is to know why.

Thanks and best regards

Spain and Stockholm2 should never have worked through the API and I don’t see how they ever did. Your API key email/information should have included a full list of the locations that the key works with as well as a link to check the location list at any time:

Hello pmeenan,

I know that both in the registration documentation and in the web that you have posted, Spain does not come out as a server to make requests from the API, but I was making requests to Spain (La Rioja) for a few days until one morning it gave me the location error that I put in the first post.

I really do not pretend that it magically works again (which I would love), if I do not understand the reason why it worked for me and not now.

Thank you for your response, greetings.

PD: iPhone(all models) stop work, Samsung Galaxy(all models) and many locations too.
It turns out that the locations have now reappeared at

The iPhone, Galaxy and many more that had disappeared, although they still do not work already appear, which gives me to understand that it has been a drop in service.

Same is for me

I’ve double checked the location list you get when you the API key and Stockholm2 is not listed there so
I don’t pretend that it magically works again.
I can give us a list of test I triggered for more than 2 weeks using API for Stockholm2

API for Stockholm2 was working and it stopped all of a sudden shows all of the locations available for users to use when using the UI to submit tests. The vast majority of those locations do not have the capacity to support API traffic as well. is a filtered version of the list that shows the locations that are available to be used with the API keys.

If it was working previously it was a bug that has since been fixed because those locations were never supposed to work with the API keys.

Hello pmeenan,

Thank you for your reply, I am very sorry that this “error” has been removed, since I think it was really useful to use it from the API and that it loses much of the utility.

Even so if it serves as a recommendation I would ask for it to be included again.

Thank you very much for the clarification.

A greeting.

Thank you for that URL which lists only the API locations - I have also been using some of the “bug” locations; bit unfortunate they don’t work any longer. Are there any plans to include any of the iPhone locations for the API based tests?

Many Thanks,
Arun Thilak

No. There aren’t enough iOS devices to handle the volume of testing required for API support.

You said some locations are not available anymore, but I still can select them from the dropdown list…
In example: I can´t use “&location=Argentina:Chrome.Cable”
but I still can select this location and explorer in the HomePage, and it works…

Is this because Argentina does not allow API anymore?