Start Render always 0 in A'dam Chrome

When I run a test for (or any other site) I see a Start Render Time of 0.0000s:

But from all other locations I do see positive start render times…

What should the mainainer of this node (that is me) do to let Chrome provide Start Render Times…

Rob de Groot

I upgraded to 2.9 earlier this week and notice I now have the same issue - I’ll have a dig in to see if I can work it out

Not sure if it somehow fixed itself or it was something in the agent update that I just did but it looks better now:

Andy, you can try grabbing the latest agents to see if it fixes it for you:

I’ll get a 2.10 release out next week (been a while and the 2.9 release needs to be manually patched for updated firefox support so it’s due anyway). 3.0 is reserved for when I move all IE testing to wptdriver and stop using urlblast at all (later this year).

Still broken for me in Chrome I’m afraid - I’ve checked the agent has updated OK, is there anything else I should check?

I know I can check it from the Windows properties but would be handy if version number was displayed in the main WPTDriver window or titlebar.

You can get the agent versions from the server: (though still not as easy when you are physically on a machine).

Any chance you had some other windows open on the desktop that overlapped with the screen shots?

Thanks for the getTesters tip - I only stumbled across getTester for the first time the other day after looking at Marcel’s node API.

There’s nothing else open on the desktop, the screenshots look fine, both Firefox and IE work OK too!

How does Chrome determine the start render - is it visually or via an extension?

For start render with WPT it is visually. We hook the drawing API’s and when something is drawn to the screen we grab a screen shot and walk the pixels and see if there are any non-white pixels.

We avoid a border to allow for the status window not to trick it but it’s possible that it is. Any chance you have an OS theme or something that would cause the default background color to be non-white?

Any chance you can send me a “start render” image from the screen shots page?

Interestingly I don’t have one - only full loaded and document complete - this is presumably part of the issue?

I’ve tried setting Chrome to about:blank on startup but that made no difference.

I’ve found that removing Chrome and re-installing it has fixed the problem for me.

Rob - do you want to try the same thing?