Start Render, TTI, and Speed Index not calculating recently

We have a private instance set up, and noticed that as of 4 days ago (Feb 20, 2020) we stopped getting Speed Index data. I believe the problem is no Start Render is being calculated, so it cannot calculate the rest of the associated visual-based metrics, including time to interactive.

I was hoping this was isolated to our instance, but it’s happening on public too. Here’s an example from just now (I tried on a few locations too):

I’ve tried to figure out what changed, and I do not see anything obvious. Compared to results that were working a few days prior, the Chrome user agent is identical, the webpagetest version is the same, video flag is still being passed…I’m out of ideas.

I’m glad this is easy to replicate…but don’t see a solution here. Anyone have any ideas?

Ah, I do see changes to the WPT Agents at exactly the time this behavior broke. It appears whatever visual calculation changes were made had some unintended consequences.


My guess is that the code change in the PR that was merged back on the 14th (and just reverted) is likely the root cause:

I probably didn’t push a new release at the time and the release was only updated with the changes on the 19th/20th and it got picked up at the same time.

I pushed a new release with the revert and the agents should pick up the change over the next hour.

That absolutely fixed it. Thank you so much Pat!