test does not wait for ads to load

When I load this page: http://sportschatter.com/slideshow/best-quotes-big-10-media-day/ in my local Chrome, the loading stops only when all ads are loaded. However, when I use WPT, based on the screenshots and a video, the document is “loaded” before all ads show up. I cannot use WPT to measure performance if it does not wait for ads to load…


What am I missing here? This issue does not occur on other sites (or at least I have not found another one).

The ads do start to appear see http://www.webpagetest.org/result/151112_YF_12CE/

You could try setting the minimum test duration in the advanced settings tab to see if they appear but in all honesty for what it’s doing the page is on the crazy side - 750+ requests and a minute+ loading time for an image gallery with some ads is way over the top.

Apparently we had occasional video ads, which added massive number of requests and weight. Took care of that…

I tried that setting, but still no ads…

The thing is that I get slightly higher page size and load times when I use local Chrome dev tools, when compared to WPT results (both instances are throttled to the same network speed).

I am trying to automate my performance reviews by employing the WPT CLI, but I need to achieve the same results as when doing it manually using the Chrome dev tools… :frowning: