Time to First Byte Takes Too Long to Load

Hi everybody,

My Wordpress powered website always takes too long for the first byte to load. This has happened since I switched my hosting to StableHost and using their dedicated IP.


I couldn’t find the problems which caused the first byte loading time. I have optimized everything I could but it always takes over 2s for the site to start rendering.

Any suggestions to fix this?

Your W3 Total Cache configuration must not be working. Is the page cache enabled? If so, what is it using for the cache (disk, enhanced disk, etc)?

Hi Patrick,
Thanks for the reply.
The page cache section is enabled. But for some reasons, I am unable to change it to Disk (enhanced). Therefore, I just leave it by default which is Disk (basic). I’m not sure if it is working right.

It looks like the page cache is working, it just may be expiring. If I run 5 tests, it looks like the first test is slow but the next 4 all return fast: http://www.webpagetest.org/result/110531_6A_QMVN/

There are quite a few knobs you can tweak on the “Page Cache” page, including a “preload” option that updates cached pages in the background (otherwise the first visitor pays the price of building the cache for everyone else).

Enabling the database and object caches may also help improve the performance for the page visits when the page itself isn’t cached yet.

Looks like you might be able to tune the css minification settings to combine the 4 different css files for the next set of improvements but it looks like the site is doing pretty good when the page is coming from cache.