urlblast not able to fire up IE - queued up

I have a newly created WPT instance in Windows 8 VM. I see that urlblast.exe is running successfully. But when I run a test for IE, no tests are executed. Chrome and Firefox are running fine.

When I run http://localhost/getLocations.php, I see that value for IE : Total Tests =17,
Being Tested =1 , High Priority = 16. (Screenshot attached). I checked the directory /var/www/webpagetest/www/work/jobs/IE/ and its empty. Anytime when I run the tests on IE 8 (from dropdown), I get a message “Waiting behind 15 tests” but urlblast.exe is just sitting with message “Waiting for next test…” . I have restarted urlblast.exe, wptdriver.exe, apache and even the VM several times, but the queue does not seemed to be cleaning up.


Startup Delay=30
Log File=C:\webpagetest_2.18\agent\urlblast
use current account=1

; Where to get work from
Url Files Url=
Location=IE 8
;Location Key=TestKey123[/code]



; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations

label=Test Location

label=“WebPagetest.org - Dulles, VA”

; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)

browser=IE 8
label=“Test Location - IE 8”

; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini

label=“Test Location”

; This is an exaple of a “remote” configuration where tests can be proxied to a remote
; webpagetest instance. The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
; To use the public webpagetest.org instance you will need an API key

browser=IE 8
label=“WebPagetest.org Dulles, VA - IE8”

Any help is appreciated. Thanks

So after reading documentation carefully, I realized that the IE 11 has to be tested with wptdriver.exe. So now, after changing the wptdriver.ini and matching it in locations.ini, wptdriver.exe can open the IE browser, but the test site never opens. The IE browser keeps saying “Waiting for…”, but never opens the url provided to test. I checked the required add-ons for WptBHO and CEIHook are enabled. I also have McAfee DLP Internet Plugin Enabled (which I have no control on to disable). Not sure if this could be an issue. I checked opening from IE and it is able to open the Webpagetest private application successfully. Totally stumped on this…

Do the Chrome and FF tests work?

Yes, the tests on Chrome and FF work. Only IE is not working. Attaching my wptdriver.ini and locations.ini (in txt format)

Did you ever get this working? I’ve run into the same issue. Tried installing ie 8, 10 , and 11, but it doesn’t work on any of those. Just stays on about:blank then times out.

Chrome and Firefox work fine.