Test returning blank pages


I’m trying to setup a private instance to work with IE. I have the server installed on CentOS and can access it via a browser. The agent is a Windows 7 machine. UrlBlast is running at startup. Everytime I run a test it returns a blank white page. I notice that the tests are being queued because I see “13 pending tests” next to test location on the webpage. I see all of the jobs in the work/jobs/IE/ directory. Thanks for any help you can provide!

Startup Delay=30
Log File=c:\webpagetest\agent\log
use current account=1

; Where to get work from
Url Files Url=http://www.mydomain.com/work/
Location Key=TestKey123



label=Test Location

label=“WebPagetest.org - Dulles, VA”

browser=IE 8
label=“Test Location - IE 8”

label=“Test Location”

browser=IE 8
label=“WebPagetest.org Dulles, VA - IE8”

Anyone? :slight_smile:

Sorry, sounds like there are 2 different issues going on:

1 - The blank white screen. You should be redirected to a test progress screen, not a blank page. This does sound a lot like what mwhite was seeing here: http://www.webpagetest.org/forums/showthread.php?tid=6181 (basically, zlib is a dependency that was not documented).

2 - The test agent isn’t picking up the work. Check your access log on the server to make sure you see requests coming in from the agent for /work/getwork.php

Adding zlib worked! I now get to a screen that says “Waiting behind 17 other tests” but that number never changes. I went into /var/www/webpagetest/work/jobs/IE/ and removed the 16 previous entries and restarted Apache but nothing changed. It still says waiting behind 17 other tests. Any idea how to fix that?

Thank you so much!

The tests not running is a result of #2. It doesn’t sound like the test agent is successfully communicating with the server. First step is to check the server’s access log to see if the agent requests for /work/getwork.php are showing up (my guess is that they are not).

You can add “debug=1” to the urlblast.ini which will spew debug information to the log file that may help but ig I had to guess I would say that something is wrong connecting to http://www.mydomain.com/ from the test agent (that needs to be the server name that is running WebPagetest and it needs to be reachable from the test agent).

When you say access log do you mean /var/log/httpd/access_log? If so, that log is not showing anything regarding getwork.php.

I added debug=1 and rebooted the Windows machine. Don’t see anything useful in the urlblast.log.

Sorry, is their anything else I could provide that would be useful in helping me troubleshoot?

Do you see the request URLs in the urlblast log? If so, can you try loading it up in a browser on the test machine?

Can you access http://www.mydomain.com/ from the test agent? If so, do you get the WebPagetest test screen?

I can access it from the test agent and I do get the Webpagetest screen. When I enter a URL and click test it says “Waiting behind 20 other tests…”

Here is what the urlblast log has:

2011/11/01 14:07:30 -1 0 1 0 0 URLBlast Started
2011/11/01 14:07:30 -1 0 1 4 0 CPU String Intel(R) Core™2 Quad CPU Q8200 @ 2.33GHz
2011/11/01 14:07:30 -1 0 1 5 2327 CPU MHz
2011/11/01 14:07:30 -1 0 1 6 3036 Total RAM (MB)
2011/11/01 14:07:30 -1 0 1 7 238315 Disk Size (MB)
2011/11/01 14:07:30 -1 0 1 8 226390 Disk Free (MB)
2011/11/01 14:07:30 -1 0 1 9 6 OS Version Windows 7 (6.1.7600 SP 0.0 Suite 0x00000100 Product 1)
2011/11/01 14:07:30 -1 0 1 10 0 Computer Name ADMIN-PC
2011/11/01 14:07:30 -1 0 1 19 0 Info Screen: 1360 x 768 - 32 bpp
2011/11/01 14:07:30 -1 0 1 11 8 IE Version 8.0.7600.16385
2011/11/01 14:07:30 -1 0 1 12 300 URLBlast Version

Hmm, looks like it isn’t starting up correctly. Try disabling UAC and make sure you are running it under an Administrator account. I’ll see if I can figure out what the next step in the startup is supposed to be and what might be stopping it from working.

Thanks - I double checked and I am an Admin, UAC and Windows Firewall are disabled. I appreciate your help!

You log looks like it ends at the end of logging the machine information and right before configuring dummynet. The only thing between those steps in the code is registering the pagetest.dll browser plugin in IE (assuming the debug=1 is working and trace-level information is being logged).

I’ve never seen it have a problem registering. You can try registering it manually from a command line by entering:

regsvr32 pagetest.dll

and see if that works or if it shows any issues. Any chance there’s a super-aggressive antivirus product that might be blocking it?

What dos the URLBlast window say for it’s status? That might provide more information as well.

I registered the DLL manually and it did not throw any errors.

The UrlBlast window shows:


Rate: N/A
CPU USage: % (% instantaneous)"

The Windows machine is a fresh install of Windows 7 with no additional software added.

When I try to test it keeps incrementing the “waiting behind x other tests” number. Up to 23 now.


Just checking in to see if you can think of anything else I could try to get this working.

Thanks for all your help.

It doesn’t sound like the “debug=1” option actually stuck. Can you make sure the log file directory exists and is writable? To get to “Running” there would have been a LOT more debug messages in the log.

C:\webpagetest\agent\log exists.
I changed the permissions to full control by everyone.

Still not having any luck both in terms of running the test or having the log file generate anymore info.

Here is my urlblast.ini does anything look off?

Startup Delay=30
Log File=c:\webpagetest\agent\log
use current account=1

; Where to get work from
Url Files Url=http://www.mydomain.com/work/
Location Key=TestKey123

It looks ok to me, that’s really bizarre. You can try grabbing a wireshark capture to see what the requests from the client look like but that’s the best option I have at this point.