wpt_batch.py errors

Hi! I have some problem with wpt_batch.py:

What did it mean?
I need allow those URLs somewhere on the server?

You probably need to specify a location as well.

Thank you, Patrick.
I really made ​​a mistake in the location, it was necessary to use location from instance config, not the one that is displayed in the web interface.

Im having this same problem and have tried specifying various locations to no avail:

wpt_batch.py -s -r 2 -o us-east-1_IE8
wpt_batch.py -s -r 2 -o us-east-1:Chrome
wpt_batch.py -s -r 2 -o us-east-1
wpt_batch.py -s -r 2 -o us-east-1-group
wpt_batch.py -s -r 2 -o ami-561cb13e
wpt_batch.py -s -r 2 -o Dulles
wpt_batch.py -s -r 2 -o Dulles:Chrome
wpt_batch.py -s -r 2 -o us-west-2b

I also tried using the External IP of the AMI.

What is the correct format for the location names?

Not sure if this is related but if i just run wpt_batch.py with no params I get the following (I can ping names and resolve ok from the cli) I have set the Python version to be 2.7 as 2.6 doesnt appear to be there:

Traceback (most recent call last):
File “./wpt_batch.py”, line 206, in
File “./wpt_batch.py”, line 203, in main
File “./wpt_batch.py”, line 103, in RunBatch
File “/var/www/webpagetest/batchtool/wpt_batch_lib.py”, line 71, in SubmitBatch
response = __LoadEntity(request, urlopen)
File “/var/www/webpagetest/batchtool/wpt_batch_lib.py”, line 31, in __LoadEntity
response = urlopen(url)
File “/usr/lib/python2.7/urllib.py”, line 87, in urlopen
return opener.open(url)
File “/usr/lib/python2.7/urllib.py”, line 208, in open
return getattr(self, name)(url)
File “/usr/lib/python2.7/urllib.py”, line 345, in open_http
File “/usr/lib/python2.7/httplib.py”, line 969, in endheaders
File “/usr/lib/python2.7/httplib.py”, line 829, in _send_output
File “/usr/lib/python2.7/httplib.py”, line 791, in send
File “/usr/lib/python2.7/httplib.py”, line 772, in connect
self.timeout, self.source_address)
File “/usr/lib/python2.7/socket.py”, line 553, in create_connection
for res in getaddrinfo(host, port, 0, SOCK_STREAM):
IOError: [Errno socket error] [Errno -2] Name or service not known

Check - it should give you a list of the locations that you configured (it is whatever you put in locations.ini).