WPT showing duplicate requests for same file


I have setup the private instance of WebPageTest (2.13). Both the server and agents are on the same machine. The test completes successfully once it is submitted. However, I have noticed that it is making two requests for almost each of the file. In the attached screenshot you can see that there are two requests for each of the file. I tried capturing the network trace, the browsers (IE and Chrome) are not making multiple request for same file for this webpage. I also tried capturing the network trace in agent machine while the test is in progress. The network trace from agent machine also does not show the multiple request for the same file.

What could be the reason that WPT private instance making multiple requests for same file?

Thanks in advance.

2.13 is pretty ancient at this point and changes in both Chrome and Firefox require updating to at least the agents from 2.14. I’d recommend installing 2.14 and grabbing the latest agents (newer than 2.14) - https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-Updating-Test-Agents and see if you still see duplicate requests.

Hi Patrick,

Thanks for your response. I deployed 2.14 and also updated the agents as you mentioned. But I’m still seeing the duplicate request as previous. I tried deploying 2.14 in two different machines (one with Windows 7 and the other with Windows Server 2008). Both of these shows duplicate requests to almost all HTTP requests. Do you have any other suggestions?


Do you have any 3rd-party firewall or antivirus installed?

Antivirus is installed. I tried disabling it, but didn’t help. Still shows duplicate requests.

Hi Patrick,

I’m still banging my head to wall to try to fix this issue. When I tried capturing the network trace in agent machine while the test is in progress, it does not show any duplicate requests. But WPT shows duplicate requests for almost all the requests. I would greatly appreciate your help/suggestion to resolve this issue.

Sorry, I have no idea - Have you completely uninstalled the Antivirus and all of it’s different modules? That’s the only thing that comes to mind. It looks like something is intercepting the traffic in-proc and re-issuing the requests (like a local in-browser proxy) which is why WPT sees the requests twice but a tcpdump doesn’t.

Were you ever able to fix this? I’m seeing the behavior for both private and publich instance

As Patrick mention, I had to completely uninstall the antivirus to solve this issue.