FireFox Fails to Test on Private Instance

Patrick - We are running a private instance of WPT and we noticed that it stoped getting test results from Firefox. The test complete with a failure, no data is collected.

I have gone through the config files wptdriver, locations and settings to ensure that we have Firefox configured properly. I have updated Firefox and WPT but that did not seem to fix the problem.

When I queue up a test I can see that the networking is correct the FF page loads but the URL reads I included a pic sorry for the quality but the blank html page will show until the job times out, which I have set at 45sec.

Have you seen this before ? or can you point me in the right direction?

Note: Chrome and mobile are working everything gets sent to Jenkins then to Graphana.

What version of the agent? You need a fairly recent build as Firefox breaks from time to time as things change.

I am using WebPageTest 2.18. This appears to be the newest version.

Check your /getTesters.php page which will list the agent versions:

The agent can update independently of the web server and there have been a lot of updates since the 2.18 release:

If you are ok with getting automatic updates for the agents there is a setting in settings.ini on the server that will fetch them automatically: webpagetest/settings.ini.sample at master · WPO-Foundation/webpagetest · GitHub

Adding the auto update worked great ! Thanks for your help.

This solution did not worked in our WPT 2.18 private instance, have been trying different versions of WPT(2.18,2.19,3.0 and 17.08). None of them works in either proxy environment or non-proxy environment, Need some suggestions :frowning: