WPTdriver - Failed to initialize dummynet

I set up a Private instance with a Windows7 test machine for agents.

When I execute WPTdriver it tells me Failed to initialize dummynet and when I execute a test from my private instance I get
“The test completed but there were no successful results”

In the error logs I don’t have any issue and the access log receive correctly the request.

What to do?
Going to the install folder I get

IE 1 Agent connected
Chrome, Firefox 1 Agent connected

Did you install the dummynet driver? - step 10 here: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-General-Machine-Configuration-common-for-all-browsers-

If you didn’t install it then you need to add a “connectivity=LAN” to your location in locations.ini so it doesn’t try to do traffic shaping.

Hi Patrick, thanks for your answer.

I realized only now that the provider tell me they give me a 32bit, but the server was 64bit.

I reinstalled the correct drivers and now it works :wink:

I have only a problem with UrlBlaster that give the error but chrome and firefox works.
The only thing is missing is the PageSpeed tab in the result. How to get it work? I must install something?

Page Speed is only available with URLBlaster and IE. If you update to the latest agents it may fix urlblaster on 64-bit for you: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-Updating-Test-Agents

Ok I downloaded and intalled the 2 files and uploaded, but IE still not work.

I read that the update is automatic but probably it isn’t.
There’s something else to do?

What version of IE and OS? What exactly is failing? does it launch IE at all?

You might need to use wptdriver (add a section for IE that points to the iexplore.exe in the x86 program files directory).

Ok so I can use wpt driver also for IE?

Which are the exact configuration? Is there a sample file for IE?

I have Windows 7 64bit and IE version 10.0.4 but URLblaster tell me that the version is 9.

The browser execute but then on the installation side I have no results.

Yes, urlblaster is only for IE 9 or earlier: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-wptdriver-Chrome-Firefox-Safari-IE-6-10-

the wptdriver.ini.sample should have had an IE sample: http://webpagetest.googlecode.com/svn/trunk/agent/wptdriver/wptdriver.ini.sample

Wonderful. Now It works also in explorer.

How to use PageSpeed?
I didn’t see the tab even if with IE.

You can’t get page speed results for IE 10 currently. Adding support for it for wptdriver is on my list of things to do.

Ahh what a bad news :frowning: eh eh :wink:

Ok let us know when it will be ready.

Thanks for all.


Is it still the case? I’d also like to know if there is any way to get Page Speed scores for Chrome/Firefox as well?

Thank you.

That is still the case. The current plan is to use the Page Speed API for the testing service and merge the results together (but that doesn’t solve the issue for private instances). The newer iterations of Page Speed include a bunch of checks for things that can not be done locally (testing mobile and desktop versions of the site) and the library that we used hasn’t been supported for several years so there aren’t really any great options.