Win2008 64bit No tests Running

Previously we have been using 32bit instances, and we are now trying to migrate to 64bit. I’ve followed our usual setup steps to get a node up and running, and everything comes up and appears to be waiting for work. The only difference was in running the testmode.cmd before installing the 64bit dummynet drivers. But when I actually submit a test, the job is immediately processed and returned “The test completed but there were no successful results.”

On the client no browser is attempted to be loaded. I have also noted that when I start a browser manually, I’m not prompted to allow the wpthook.dll that I get prompted on the 32bit machines the very first time (I think that’s the DLL). Last I checked, there was no logging option in the wptdriver (perhaps that’s been added recently?), so I can’t even diagnose what the problem is.

From all external appearances I now have a running 64bit WPT node, but it just won’t process any tests and I don’t know where to start digging. Thoughts?

The instructions for the 64-bit wptdriver say to:

  1. Copy the 64bit version to the dummynet folder.
  2. Install the 64bit driver by browsing to the 64bit folder.

This caused a little confusion and I tried to just install/use the 64bit dummynet driver from the 64bit folder. After copying it directly to the dummynetfolder and reinstalling, it seems to have fixed the issue.

Hmm, you should have been able to use it from either location but I cleaned up the docs to point to the dummynet folder instead (installing from the 32 or 64-bit should have worked but the files need to have been copied as well).