I can't connect to the test agent after installing the dummynet service

I’m following the instructions to setup WPT 2.10 on a Windows 2012 server (64bit) and it all goes fine until I install the dummynet service at step 10. The RDP connection drops as expected after installing, but then I can’t re-connect to the server. Rebooting it from the hosting control panel doesn’t fix it. I’ve tried this 3 times now & it happens each time, I’m not sure what I’m doing wrong.


Did you run the testmode.cmd as an administrator before installing the driver? You may also need to reboot before it becomes effective (look for a test mode notice in the bottom-right corner of your desktop).

If you did go into test mode and reboot, then it’s possible there is a driver incompatibility. I had issues when I tried to install it into Amazon’s server 2012 AMI’s and I haven’t been able to debug it (since the server becomes unreachable right after install). I haven’t been able to reproduce it locally in any VMs.

Hi Patrick, yes I did run the testmode. I also tried it with a 32 bit Windows 2008 Base VM & it did exactly the same thing after installing the service. This is on AWS

Yeah, I have a scary feeling that the new paravirtual drivers that Amazon installed on their EC2 images doesn’t agree with dummynet. I haven’t had a lot of time to look into it yet though.

I have 2008 server AMIs that use the older drivers if you want to use that as a base: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-AMI-Images but it’s not R2 so no way to get IE 10 onto them yet.

Same happens to me when installing on Windows 2008 32Bit ec2 instance.
Patrick are there any news about that ?


No good news anyway. It’s impossible to debug and I can’t reproduce it on vanilla Xen or any other VPS infrastructure so unless they release new drivers, dummynet gets updated for other reasons or we find a new way to traffic shape that does work it doesn’t look too good.

Ok.Thanks for the update.
Say, Can i install multiple agents on same EC2 Test Agent AMI ?
Because i don’t have the credentials to remotly log in these machines…


The guys at Radware managed to track down Server 2008 R2 AMI’s that had the old network drivers so we’re back in business. IE 10 and 11 AMI’s are now available in all of the locations: https://sites.google.com/a/webpagetest.org/docs/private-instances#TOC-AMI-Images

There are still a few bugs on the measurement side with IE 11 that I hope to get fixed today but the AMI’s themselves won’t change.

If you want to tweak the images and do your own setup, just go ahead and launch an instance and then make an image from it.

I was running into this same issue, we tried a bit of everything on AWS, including running:

[]Windows Server 2003
]Windows Server 2008 32-bit
[]Windows Server 2008 64-bit
]Enabling test mode/rebooting
[*]Prebuilt AMIs

The prebuild AMIs seem to be a good option, the only thing is that we could not get a password for them. So we tried Microsft Azure. The agent worked right of the bat, and dummynet works like charm. Most importanltly it accelarated the developement of our solution. I’m not a fan of Microsoft, but you might want to give it a try.

Azure works great - I have an issue open to support auto-deployment there, just haven’t had a chance to implement it: Add support for running agents on Azure · Issue #23 · WPO-Foundation/webpagetest · GitHub (yeah, it’s 8 months old).

The main issue is just figuring out if there is an equivalent of EC2’s user data and how to retrieve it.

btw, the Admin password for the EC2 instances is “2dialit”. Just make sure you lock down RDP so it’s not open to the world since it’s a well-known password.

I just ran into the same issue running Windows 2008 RC2. Has there been any progress with getting the EC2 instance drivers (specifically Citrix PV) to work with dummynet?

None that I am aware of. The guys at Radware found some AMIs running the redhat net drivers which is how we were able to set up IE 10 and IE 11 AMIs.