403 Forbidden at localhost

I have completed the setup for WebPageTest. Apache and PHP are installed as per instructions given in readme.html.

When I try to access http://localhost, I get:
403 Forbidden

You don’t have permission to access / on this server[/b].

Can anyone help? Here is a snippet from Apache error.log:

[Tue Mar 30 22:08:01 2010] [notice] Child 3920: Starting thread to listen on port 80.
[Tue Mar 30 22:08:10 2010] [error] [client] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/runtest.php
[Tue Mar 30 22:17:19 2010] [error] [client] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/
[Tue Mar 30 22:17:22 2010] [error] [client] client denied by server configuration: C:/Program Files/WebPageTest/Web Site/content/

And access.log contains: - - [30/Mar/2010:22:07:38 +0100] “GET /runtest.php?url=www.aol.com HTTP/1.1” 403 213 - - [30/Mar/2010:22:08:10 +0100] “GET /runtest.php?url=www.aol.com HTTP/1.1” 403 213 - - [30/Mar/2010:22:17:19 +0100] “GET / HTTP/1.1” 403 202 - - [30/Mar/2010:22:17:22 +0100] “GET / HTTP/1.1” 403 202

Any help much appreciated!


Are you using the default .htaccess file? What does your httpd.conf look like (do you have AllowOverride enabled?) Looks like a problem with the apache config.

Thanks for your response Pat. I am using the default htaccess file (have not changed it). However I had made a mistake when updating the httpd.conf file: When installing WebPageTest, I put it here:
C:/Program Files/WebPageTest. Therefore I needed to update the httpd.conf file (provided by yourslelf) so that all references to WebPageTest pointed to that location. This is did, but unfortunately I missed a few!

I’ve now corrected this and all working fine!

Thanks very much for your help.



I followed Andy Davies step-by-step guide http://andydavies.me/blog/2012/09/18/how…-instance/ to setup the configuration.

Here is my code:



; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations


; These are the browser-specific configurations that match the configurations
; defined in the top-level locations. Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)

browser=IE 9
label=“Local - IE 9”

; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini



Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
use current account=1

; Where to get work from
Url Files Url=
;Location Key=TestKey123


;Automatically install and update support software (Flash, Silverlight, etc)

exe=“C:\Program Files (x86)Google\Chrome\Application\chrome.exe”
options=‘–load-extension=“%WPTDIR%\extension” --user-data-dir=“%PROFILE%” --no-proxy-server’

exe=“C:\Program Files (x86)\Mozilla Firefox\firefox.exe”
options=‘-profile “%PROFILE%” -no-remote’


I have installed the DUMMYNET ipfw driver and started testmode.cmd too.

when i am starting urlBlast.exe, i get installation failed…It keeps trying to install. And wptdriver.exe is clicked , small window opens and shows cpu usage etc…but no change in it as such…
when i trying to open http:L//…i get Forbidden 403…
Can someone help me in this?

Thanks in advance

I think you must have urlblast and wptdriver mixed up. urlblast displays the CPU usage and wptdriver does the software install.

You can bypass the software installs by commenting out the “installer=” and “software=” lines in wptdriver.ini.

As far as the forbidden when navigating to, is your apache running? Does the apache user have permission to read from the directory where the website code is?

Sorry, for mixing it up…I have commented out those lines from wptdriver.ini.

yes, the Apache user has permission to read from the directory where the website code is.

In my office network, they dont allow me to set dummynet…so i have skipped that part too…And i am using 2.9 version of webpagetest. My machine is Windows 7 Enterprise Edition with 64 bit OS.
Please help me to configure webpagetest.

Thank you

Your first step is to get Apache working so that you aren’t gettign teh 403 errors and that’s completely independent of the webpagetest configuration and settings.

Can you look at your apache error log and see if anything in there indicates why you might be getting errors?

Apache and php version crashed each other. I have resolved it.
Now my problem is i dont get any results. I get
“The test completed but there were no successful results.”
I am running WebpageTest server and agent on the same machine Windows 7 prof. I have used 2.9 webpagetest.

That is probably because of dummynet. Your locations.ini needs to be modified to specify connectivity=…

browser=IE 9
label="Local - IE 9"


That is needed so that WPT doesn’t attempt to use IPFW for traffic shaping.

I have changed locations.ini but still i get the same result. But i can see some changes in the URLBLast log file:

Browser Launched Cleared Cache-Run_1!http://google.com
Browser Lauched Cached-Run_1^http://google.com

i dont know how to resolve this.

Hi Patrick Meenan
To add to my previous post my Web server and test engines are running in the same machine, which is VMware Windows 7 Prof VM.

Can you tell how webpagetest know that a particular webpage is completely downloaded?
Thanks in advance

If you browse to does it give you a list of the agents?

I had fixed the issue.
But i couldnt view any pictures. But results are showing up.
To view the pictures what should i enable.


The screen shots only or are the waterfalls also not showing up? Most likely would be that the php gd module isn’t installed. If it’s just the screen shots and they are coming up as black images then a screen saver, power management or a locked desktop is causing the issue.

Hi Keerthika,
how did you fix the no result issue, I’m facing the same issue on my webpagetest.