Android - startAgent

hello !

i try to make privates instances to have test on Android device
but i have a problem when i start agent

someone have an idea ?

Thanks in advance

use the wptdriver.bat version on Windows, the .sh is for linux. I’m actually surprised it runs at all.

Yes thanks Patrick !
i use the wptdriver.bat ans it’s better but i have a problem again

maybe i think i have a problem with parameters ?

at a minimum you should get rid of the 's in the command-line. Those are continuation characters for multi-line commands but will just mess up the single-line command.

i’m not sure to really understant… i’ll try the same command line without
but i’have the same error

Sorry for your help…and sorry i’m neebie in command line :slight_smile:

i’ll try to edit wptdriver.bat file and modify defaut value by mine value. And i just execute batch file without parameter…i have the same error

Up
i try to edit again batch file and i see the problem is here :

set “BROWSER_ARGS= --browser browser_android_chrome.BrowserAndroidChrome --deviceSerial %DEVICE_SERIAL% --captureDir ^”%AGENT%\lib\capture^"%CHROMEDRIVER_ARGS%"

i haven’t capture folder or file…
do you know were i could find it ?

Try removing the

--captureDir ^"%AGENT%\lib\capture^"

part entirely. That is for supporting HDMI video capture and isn’t used for android anymore. It being missing shouldn’t cause a problem but I expect the command-line being passed is causing quoting problems.