are mobile device tests working?

Hi, I’m unable to get any good results from the android or iphone devices in Dulles, VA. Simply getting

The test failed to run.
timeout

and the screenshots show an about:blank page. Have tried a few times today.

However, the waterfalls are showing all the right requests, so I am assuming they are working, which may be good enough for now :slight_smile:

Do you have a sample result?

Here’s an Android test I just ran: http://www.webpagetest.org/result/140910_76_K21/

and iOS: http://www.webpagetest.org/result/140910_4S_JWN/

I’m having similar issues. I’m trying some VERY basic script tests using setDnsName and Navigate through the webpagetest UI , and even the most basic script “navigate” by itself fails

iPhone 4 iOS 5.1 - empty result
http://www.webpagetest.org/result/141127_N8_d034a04a09849c914938691672661d7d

Nexus 5 - getGUID error
http://www.webpagetest.org/result/141125_JG_10157e228439c339eb0ec0b483c060e0/

Interestingly enough, when I switched from 1 run to 2 runs, and turned on repeat view, I seem to get a little more success, albeit with an error or two
http://www.webpagetest.org/result/141127_RB_b450e7aaaf67f961c9f5738ca55323b0/

As a side note, I’m just trying to understand what capabilities wpt has around actual mobile testing and validate what scripts work across HTTP/HTTPS across various devices.

Hi, I thought I’d bump this again. I tried a sample test again

Simple Navigate
http://www.webpagetest.org/result/150119_CR_fb2256d5676f74fc8d307c7a2ee95314/

Navigate + setDnsName
http://www.webpagetest.org/result/150119_75_0f26f443c8d6c77847974fef2d1caad9/

And I get Object # has no method ‘getuid’. I believe I saw the UI say setDnsName and navigate are valid, so I’m struggling to understand if I’m doing something wrong.

The mobile agents don’t support the WebPagetest scripting (yet anyway), no matter how basic.

Thanks Pat, the UI gave a warning and a sample script on my first attempt (late November?) saying only setDnsName and navigate were supported, so I thought that had been addressed.