Chrome issue

webpagetest failing in chrome.It says the test completed but there were no successful results
I use windows server SP2 64 Bit OS.
32 bit Chrome browser

If you watch the test agent when you run a test do you see the browser start? What is the version of wptdriver.exe?

I have a scheduled instance running in the background (task scheduler).
Things were working fine. I have been observing this since a week.
When I stop the scheduled instance and run wptdriver.exe in the foreground, it picks up the test and runs, but shows a longer delay.
Also shows ‘your profile doesn’t exist’

wptdriver.exe running from task scheduler runs FF tests properly. The issue is only with chrome.
Your help is much appreciated

WPT generally doesn’t support running in the background. Do you have the task configured to only run when a user is logged in and at the time of login (and using the account of the user that you have configured to autologon)?

Run whether the user is logged in or not.

But it did work for me and broke all of a sudden, that too only for chrome. wptdriver-FF combination works good from task scheduler.

Just wondering if its a Chrome or Windows OS (task scheduler - background job vs foreground) issue? Earlier the same combination worked all OK…only some unknown change somewhere (like security patching for OS and browsers etc) could have resulted into current status?

Which windows server (2008, 2008R2, 2012)? I can see if I can reproduce the issue.

We have around 60 agents with OS either WS-2008-SP2 or WS-2008-R2-SP1

Chrome browser ver. shows Version 38.0.2125.111 m
while looking for chrome version info it autoupgraded to Version 38.0.2125.122 m.

also curious on that point i.e…should autoupgrade of chrome browser version cause any issues? Want to know recommendations on that as well on chrome pop-ups like “your profile could not be opened properly”


No, The Chrome auto-updates should be fine. All of the test nodes I run are always set up to auto update.