Crazy First Byte Times

I ran a page speed test and am getting really slow First Byte Times of between 30s and 46s. I recently noticed this after I “upgraded” to a dedicated ip address.

I attached a screen shot. Any help would really be appreciated as I just lost my Page Rank from Google for slow page speed.

Were there any other changes when you moved to the static IP? For example, did you have W3TC or supercache enabled and maybe it didn’t make it over?

First byte times are basically a black box from the outside and the only way to really figure out what is going on is to instrument the app itself. First byte time problems on wordpress usually come from slow database queries or plugins that make calls to external services. A caching plugin can hide the problem but to actually improve things you need to identify the cause and fix it.

There are some plugins that will give you the database query times (W3TC can log them as well). If you have access to install php modules, New Relic can also do some amazing instrumentation automatically.

I really appreciate you looking into the issue further, but I have been doing testing for a while now with it always having issues. It’s not just a few minutes, it’s consistently 2-3 seconds for some files for the initial connection.

Here is another test completed just now:

Some files (2) on cloudfront had over 6 seconds before the first byte.

How do I elevate the level of attention this deserves as im sure others are having this issue without being aware.

OK, I’ll have to change the direction I was heading, because (as I’ve just learned) CloudFront doesn’t honor the Cache-Control headers. Sorry about that.

However, (using as an example) since that object wasn’t already in the CloudFront cache, the time to get that object from the origin is included in the Time to First Byte metric.

I agree that the times seem unusually long, but that’s sometimes why people use a service such as CloudFront-- to shield their users from latency problems at their origin.

Retrieving that object directly from your origin takes me on the order of 2.7 seconds from New York, and about 3.3 seconds from San Francisco. (I tried it only twice from each location.) (And of course those times are going to show up directly in your Time to First Byte metric.)

I have tested this object, and it seems to continually show up as a “X-Cache: Miss from cloudfront”, so we are looking deeper to see if we can tell why it’s not staying in cache.

Does this help, or am I misunderstanding what you’re trying to resolve?