Firefox not working and CSV filename issue

I have the agent set up on a 64-bit windows 2008 server and IE and Chrome are working like they should right now but Firefox always opens Chrome instead it runs through just fine though. I also tried changing the browser=Chrome to browser=Firefox in the wptdriver.ini and it did load firefox after that but it just opened to the default startup page and went nowhere from there.

Also, when I try to download any of the files as Raw page data or Raw object data for IE or Chrome, the filename is always csv.php, is there any way to get it to get them to name the files like on the public instance?
my locations.ini is:


label="Server1 (IE8, Chrome, Firefox)"

browser=IE 8
label="IE 8"


and my wptdriver.ini is:


options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --new-window --no-first-run --no-default-browser-check --enable-experimental-extension-apis'

exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'

Are you submitting tests through the UI or through the API? I just fixed a problem with the location parsing if you were using the API for submitting the tests. If you were using the UI then I’m not sure - your config files look like the stock files and should work fine.

I am using the IU to initialize the tests, so it might work if I try running it through the API? And what about the csv files saving as csv.php? is there any way to fix that?

No, that wouldn’t be it - the UI always worked ok, it was the API that was having issues. The csv.php is an artifact of the code not specifying a file name and rewrite not being enabled. I just updated csv.php to specify a default file name. You can either grab the trunk from svn or wait for the 2.6 release which will be coming tomorrow or Friday.