Help me to optimize "W3 TC" plugin for WP

We have new Wordpress site www.nsi.ge

WebPageTest recomendation for me:
“If you are running a site based on WordPress, the W3 Total Cache plugin makes it easy to optimize your site.”

We installed W3 Total Cache plugin, but I want to help for optimization this plugin. Please, can anybody help me :wink:

Have you followed the installation steps here: http://wordpress.org/extend/plugins/w3-total-cache/installation/ ?

I can probably walk you through some of the basics if you want to do the optimizations (otherwise there are other members here who are professionals who can do the actual work if you aren’t comfortable doing it). Looking at a test result : http://www.webpagetest.org/result/110420_51_fdc326f6fcf94b3267d52f9f32a9e656/ it looks like a couple of quick tweaks should be able to help significantly (start render 50% faster, repeat views significantly faster).

Please, Patrick - I trust you.
and I can give you entrust our own password (for Wordpress > admin: xxx, password:xxx). help me, please to optimize this plugin to make it work more efficiently.

Hi, Pat.

(q. about W3 Total Cache)
After disabling some unnecessary plugins, I see a message:
“One or more plugins have been activated or deactivated, please [empty the page cache] and check your [minify settings] to maintain the desired user experience.”

and what should I do? I’m afraid to spoil the site. Please, give me advice.

Go ahead and click on the buttons for each. That’s just for W3 TC to update the cached version of the pages - it’s normal and expected.

Thanks Pat :wink:

Dear Pat,

Is it tests real? - our site load time = 2.1 sec.?
This test is differetnt rather than WebPageTest results:
http://tools.pingdom.com/?url=nsi.ge&treeview=0&column=objectID&order=1&type=0&save=true

Be a little careful using pingdom for performance tests. They run the tests at backbone speeds and use a simulated browser (that doesn’t execute javascript). It is good for testing availability but I wouldn’t recommend using the performance numbers from there.

I believe gtmetrix, browser mob and yottaa all have spot-tests available that use real browsers (though they all run at backbone speeds so understand that real results are likely to be slower for most users).

Thanks,

-Pat

The plugin is not easy to use. Moreover, optimization requires code fixing in most cases.

This is a bite of my experience http://mytech.dsa.me/en/site-optimization-w3-total-cache-problems

I’m not sure I’d agree with that assessment. Yes, turning on some of the features requires more than just checking a checkbox but I’ve used it on several non-trivial sites so far and haven’t had any issues. The author is the CTO at Mashable where it is also used and there are a lot more favorable reviews than negative ones.

On the whole it’s a LOT easier than hand-optimizing a wordpress site, particularly one with lots of plugins but it’s not as easy as if wordpress were just fast by itself. Make sure to provide feedback and ask questions directly in the forums area for W3 TC and I’m sure they will be addressed.

After 2~3 days, installing of W3 Total Cache plugin I, in my Admin page have massage:
{ Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/nsige/public_html/wp-includes/class-simplepie.php on line 1486 }

Very usefull and interesting instruction of resolving this problem I find in this site:
http://perishablepress.com/press/2008/02/17/wordpress-error-fix-increase-php-memory-for-cachephp/

I opened php.ini and .htaccess files and put it in the directory “wp-includes”. But I have result only changing the in end of “Fatal error” massage, - number of line (1486 >> 5410):

I have now new massage:
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/nsige/public_html/wp-includes/class-simplepie.php on line 5410

  • I was informed form hoster that PHP Configuration > memory_limit 24M is unreal and I must open own php.ini in directori to take full memory resources (but <200M). I open php.ini (+ .htaccess in directory wp-includes) and insert there 128M

I think allso, that my Data base is full or not ;( (with red collor in cPanel)…

@pmeenan
Hy pat,
If you have little time, please help me. After installed W3TC I today discovered this problem:
http://www.webpagetest.org/result/110517_T9_MCNJ/1/details/

That’s not going to be related to W3TC. That is a networking or hosting issue - the test system is having intermittent trouble connecting to your server. I spot checked a few other tests from Dulles and don’t see similar issues. You should reach out to your hosting provider to see if they are having any issues.

Dear Pat,
I just tested for Chrome 11
http://www.webpagetest.org/result/110517_JJ_MFQH/1/details/#request65
What kind of problem is here >> request #65 ?
Is not it any viruse?

That’s an OCSP certificate validation check. It’s probably for a SSL request that doesn’t show up in the waterfall because we don’t support tracking SSL requests in Chrome yet.

Put your php.ini file in wp-admin folder. Had the same problem this morning, fixed immediately by bumping up memory_limit and placing the php.ini file in wp-admin folder.

Hi, iliketheride :slight_smile:

ou a simple file PHP.INI ? and had been guilty of?
ou I can’t imagine this solution !

Many, many thanks to you iliketheride, you can not imagine how much I was looking for the solution of this problem. as well that I waited for your good advice. Many thanks also to this forum, and specifically Mr Pat :slight_smile:

Problem instantly disappeared ! :slight_smile: