How much more can I do ?

I’ve spent the past two days optimizing my blog and my forums.

I’m using MaxCDN, I’ve put most of my images over several sub domains through MaxCDN. One thing I can’t get rid of is those E-tags. Also on the forums I’ve not touched any of the javascripts yet.

Any tips would be greatly appreciated :D[/align]


  • FYI, your page layout is completely broken on Firefox 4, IE9 and Chrome 10 on a wide screen :slight_smile:
  • Looks like it is a wordpress blog, install W3 Total Cache to help with the first times
  • Merge the css and javascript files together into one of each (W3TC makes this REALLY easy to do)
  • What is the “mint” call? It is blocking and should be moved/removed if it can be
  • If you can move the javascript to the end of the page, even better
  • Make sure you are using the async snippet for GA:
  • Wow, that’s a big background image (though not really byte wise). It looks like you should be able to set a body background color and just use images for the top pieces on either side.
  • For some of those image elements (not the photo thumbnails but pretty much everything else) you should be able to use a sprite for them and combine them into a single image

  • ACK! RUN and fix persistent connections on the domain.
  • Make sure you’re using the async analytics script
  • What is the “mint” call? It is blocking and should be moved/removed if it can be
  • Looks like there is already some js combining going on, just need to add the other 2 files to it
  • LOTS of image icons that should/could be combined into sprites

Here is the screen shot

Screen is 1920x1200 if that helps any.

ah so your screen is so large the background is repeating and that is causing the board to go out of the middle. I will add no-repeat and can you try again.

edit, can you try now ?

Nope, still broken. Is the CSS being served from the CDN? If so you need to purge their cache as well (though generally you’d want to be changing the file names or adding a version parameter to bust the cache).

I’ve fixed it, but now I’ve got to work on the page again, had to use my old backup.