Issue with Chrome and Firefox in WindowsSever 2012 Agent

Hi Patrick,

I setup WPT agent in Windows Server 2012 (64 bit). On this agent, test runs fine in IE however, Firefox and Chrome are not able to run the test. When the test is submitted for Chrome, it is giving “Timed out waiting for the browser to start”. However when I look at the agent machine after the test submitted, it starts Chrome and navigates to http://127.0.01:8888/blank.html and then http://127.0.01:8888/blank2.html. But it does not navigate to the requested URL. I tried updating the agents but it did not help.

IE is working fine without any issue.

Here is the state of Agent Machine
WPTDriver use is 2.15 (also tried updating to latest)
OS: Windows Server 2012 (64 bit) - Hyper-V VM
No antivirus is running

ipfw.cmd is giving following message:
1 [main] ipfw 5108 find_fast_cwd: WARNING: Couldn’t compute FAST_CWD pointer. Please report this problem to the public mailing list

Not sure if this is the issue. Throttling seems to be working fine when running the test on IE.

Attached screenshot is from the machine when it launches the Chrome.

Appreciate your input. Thanks in Advance!!

As a sanity check, did you install the 32-bit version of Chrome? It doesn’t look like the agent code injected into the browser.

Yes, it is 32 bit version of chrome.

Shouldn’t have anything to do with the ipfw message. For some reason the code injection isn’t working for Chrome and Firefox. IE uses a different way to load the code into the browser process and both Chrome and Firefox rely on App Init dll’s. Usually it only requires a registry key to enable them to load but it’s possible that they are disabled if secure boot is somehow enabled or if there is a group policy coming into play.

Hi Pat,

We are experiencing this issue as well.

We have it all working on ESX (windows 2012 R2, running chrome, IE and FF) but the same setup on Hyper-V results in the chrome browser loading Blank2.html and giving a error.

We have deployed 7 private instances on ESX and all work, and 4 on HyperV and all failed (on chrome).

Very strange…!

Happy to provide any logs if need. (Just ask)

Is the hyper-V server also 2012 R2 (standard, datacenter or other)? Also as a sanity check, you installed the 32-bit version of Chrome, right (you have to work pretty hard to get the 64-bit of stable so I’m assuming that’s the case).

I recently set up an instance on Azure but it’s been a while since I’ve tried Hyper-V (never had an issue with it though). I can dig up a spare machine and try it out.