missing start render and screenshots

I am monitoring a website and recently noticed that one of the three locations I am using on webpagetest.org is returning results that does not contain a start render time or screenshots. They are all from the Dulles location and have happened several times in the last week and a half. Here are four of the most recent results:


Has anyone experienced this before? I tried searching the forums but did not see anything related to the missing start render times. I want to make sure this is an internal issue on our end before contacting my IT department.

Thank you,


There were a handful of machines where the display stopped working for some reason (never seen Windows 10 do that before). I rebooted those this morning and they should be good again. I’m looking into a way to detect when that happens and have the agents go offline instead of running bad tests.

Thank you for doing that. However, it appears to be back. I am seeing the same result again when I run tests. Below is an example link of what I am seeing.


It has happened 11 times in the last 8 days. I am grabbing the XML file and then building a graph to display our times as an independent audit. See the link to an image of the graph below:


Each one of the dips to zero indicate when the server is experiencing the problem. I hope that helps you narrow down the problem. In the interim, I will modify the missing data to display these as the average time so that it does not skew my results.

Again, I hope you figure out the issue. Your site and resources are a huge help in convincing many people in my company that we have issues that need to be fixed.

I rolled out a code update yesterday that should prevent machines from testing (and automatically reboot them) if the display capture is having issues. Still not sure exactly what is causing it but Windows 10’s display system in the VM’s seems to go completely unavailable after a while (months). The detection and rebooting should mitigate the issue so let me know if it STILL pops up after today.