Missing video frames / filmstrip images


I have a private WPT instance running and it’s been running perfectly for months. Recently though it developed an issue with video capture. Only 2 video frames are captured; the first (blank) and the final frame (fully loaded). Previously it was capturing things correctly and showing me the loading progress with 100ms resolution. Here’s some things I’ve noticed during analysis:

The tests agents and server are running fine and not logging errors.

The results are being saved ok and you can see the 2 frames that are captured in the video_1 directory.

It can create videos from the frames that are captured so i guess AVSynth and ffmpeg are working. It’s just capturing the frames in the first place that isnt working.

This affects all browsers that I’ve enabled (chrome, firefox and IE)

Usually i’m logged in over RDP but it doesn’t make a difference if I connect a monitor and login normally.

I’ve upgraded from WPT 2.8 → 2.9 but that hasn’t fixed it.

I’ve trawled the forums and the google for similar problems but cant find anything similar reported anywhere. Does anyone have any ideas what this might be caused by?



The only thing that comes to mind would be hardware-accelerated rendering but I would expect it to impact IE and Chrome differently (and urlblast should be disabling it on IE). You can try going into the IE settings and checking the box to use the software renderer to see if that helps.

Thanks for the reply Pat.

I’m running IE8 which apparently doesn’t even have hardware rendering? I tried disabling chrome’s various hardware acceleration features in about:flags but it didn’t make any difference.

The other thing to note is that on the blank (white) frames that show up there are often artefacts on them - usually other bits of the screen that have been captured like explorer windows or desktop icons or random bits of window borders. Does this point to a misconfiguration in whatever is doing the screen captures? Perhaps it’s looking in the wrong place or at the wrong window?

I have the same problem. Only a blank and final frame are captured. When I use the public WPT version everything works fine.

In IE8 all works fine. I have to problem with Chrome and Firefox.

Which settings can I check in trying to fix this problem?

I tried enabling/disabling hardware acceleration in Chrome without any success.

My first recommendation would be to grab the latest agent code just to make sure you are running what the public instance is. Hardware acceleration is no longer a problem.