Mobile test

I tried to spoof the user agent through a script, like showed in the script documentation, but I receive different results from the mobile user agent localized in Dulles.

There is a way to obtain truthful results through spoofing? Or is it possible to install Mobitest agent into an emulator to interact with a private instance?

It depends. Spoofing will tell the server that UA string but javascript-based detection or css media style rules will not necessarily match. You usually want to also include setViewport to change the browser size to match but even then it’s not exact.

Sure, you can install the Mobitest agents in emulators, they work fine there.

As Pat says, it’s pretty straight forward - I got this up and running earlier this week, only issue I had was I needed to upgrade to WPT 2.9

Will write a blog post about it in the next few days.

Could you reply to this post when you write your blog post? I would be very grateful for that.

Sure, will probably be early next week.

Here’s how I added iOS agents to my WPT instance http://andydavies.me/blog/2013/03/05/adding-ios-test-agents-to-a-webpagetest-instance/

I’ve tried to install the mobitest on an Android emulator with a Cyanogenmod image, I configured both the server (Windows server) and the emulators to interact each other, but when i poll the server with my private instance (webpagetest version 2.9), I get only the server datetime from apache. Can anybody help me?

What happens when you type http://your.wpt.server/getLocations.php into a browser?

Is the Android agent listed, if so what’s it’s status is it idle or processing jobs?

I’ve solved the issue after a lot of tries but now i have another problem: the tests agent does the test, it uploads the result but all the files it upload are empty and so on the private instance of wpt i get “First View: Test Data Missing”. Taking a look to the raw object data, it contains only the names of the column.

Here are the settings of my private instance and of the test agent:

–Test Agent–
Job URL 1: the ip of my private instance
Location: TORINO-ANDROID
Unique Name: Android
Location Key: TORINO-ANDROID-KEY
Base Path: /data (i changed it because i don’t know why but i can’t mount the sdcard in rw mode)
I left all the other settings as default

–Locations.ini–

[TORINO-ANDROID]
browser=Android
latency=0
label=“Android”
key=TORINO-ANDROID-KEY

Check your http:///install/ page and make sure all of the filesystem permissions and post file sizes are ok. It sounds like there was a problem with posting the test results to your server.

Thanks for your fast reply!
This is the situation:

http://img18.imageshack.us/img18/3244/cattura1d.png

I think it’s all ok. Or not?

Yes, the server-side looks fine. You are using the Mobitest agent from here: https://code.google.com/p/mobitest-agent/ , right?

What version of Cyanogenmod? What is the emulated device?

Yes, it’s that. I’m using the version 7.1 of Cyanogenmod (API level 9) on an AVD of a generic 3.7" WVGA device with CPU ARM, 512mb of RAM, VM Heap 32, internal storage of 1GiB, using host GPU

EDIT: after some other tests i’ve noticed that on the server i get the screenshot of the loading of websites, but the har files are totally empty

Did you install the su command? https://code.google.com/p/mobitest-agent/source/browse/trunk/mobitest-agent/Android/BZAgent/README

That can happen if the agent doesn’t have permissions to run tcpdump.

Yes, I did. I’ve checked if blaze agent appears on the list of allowed application on superuser and it does. I also have tried to capture some traffic with tcpdump maually using the terminal and it works. Finally I’ve tried to execute blaze agent with the debugger of eclipse enabled and both from emulator and from a physical device i obtain the same error. I’ve pasted it here: http://pastebin.com/b3RY6xrP and, just in case, i’ve pasted the entire capture of a test here: http://pastebin.com/tmYhkRZ3

I’d recommend opening up an issue on the mobitest-agent project to see if one of the developers knows more about what’s going on with it and include the error traces.

https://code.google.com/p/mobitest-agent/issues/list

I’m pretty sure it will email everyone when the issue is opened.

Ok, i’ve notified the issue.

Thank you very much for your help!

Hi Francesco7

Did you ever manage to get your Android testing working?

Ive been stuck at the same point for months, and tried the Velodrome and BZAgent, both have the same issues.

I have tracked it down to a reponse from the server of 0 bytes on the Har File this then results i the Json not working and no data being displayed.

Both apps seem to use the mobile/pcap2har.php… and this is what i think is not functional.

Look forward to hearing others thoughts.

Steffen