SSL negotiation time


I’ve just noticed that despite there is obviously SSL negotiation time visible on waterfall, it is reported to be 0s in the table and request details

I am using 1162 revision of my private instance.

Could it be you are testing with Chrome or Firefox with SPDY enabled on your site or CDN ?

That is not handled very well (yet) with WPT.

I test with IE. It is problem with reporting. SSL negotiation time is obviously registered by the agent, visualized on waterfall but not reported in details of connection.

Any chance you can publish a test to the public instance? (publishTo in settings.ini will add a link to the top-right of each results page which will let you push an individual test to the public instance as a private test).

Hi Patrick,

Unfortunately I can’t. It may contain some confidential information. Too much risk for me.

I will try to reproduce it on some public site.[hr]
These are examples of such behavior:

Thanks, that helps. I opened a bug to track it but I expect it will be a really easy fix (probably a field name mismatch or something like that)

All fixed, thanks for the heads-up (was a mismatch on a name when we renamed the stats internaly). You can grab the fix from SVN here: